SurfaceFrame

Returns a plane based on the normal, u, and v directions at a given surface U,V parameter.

Syntax

Rhino.SurfaceFrame (strObject, arrParameter)

Parameters

strObject

Required.  String.  The object's identifier.

arrParameter

Required.  Array.  An array containing the U,V parameter to evaluate.

Returns

Array

The plane at the specified parameter if successful.

Null

If not successful, or on error.

Example

Dim arrSurface, arrPlane

arrSurface = Rhino.GetSurfaceObject("Select a surface")

If IsArray(arrSurface) Then

arrPlane = Rhino.SurfaceFrame(arrSurface(0),arrSurface(4))

Rhino.ViewCPlane , arrPlane

End If

Also See

EvaluateSurface

SurfaceClosestPoint

SurfaceNormal