Returns or sets the isocurve density of a surface or polysurface object. An isoparametric curve is a curve of constant U or V value on a surface. Rhino uses isocurves and surface edge curves to visualize the shape of a NURBS surface.
Rhino.SurfaceIsocurveDensity (strObject [, intDensity])
strObject |
Required. String. The object's identifier. |
||||||||||
intDensity |
Optional. Number. The isocurve wireframe density. The possible values are as follows:
|
Number |
The intDensity is not specified, then the current isocurve density if successful. |
Number |
The intDensity is specified, then the previous isocurve density if successful. |
Null |
If not successful, or on error. |
Const rhObjectSurface = 8
Const rhObjectPolySurface = 16
Dim strObject
strObject = Rhino.GetObject("Select a surface", rhObjectSurface + rhObjectPolySurface)
If Not IsNull(strObject) Then
Rhino.SurfaceIsocurveDensity strObject, 8
End If