Returns User Text that is stored on an object. For more details on User Text, see the discussion found in the User Data Methods summary.
Rhino.GetUserText (strObject [, strKey [, blnAttachToGeometry]])
strObject |
Required. String. The object's identifier. |
||||||
strKey |
Optional. String. The key name. If omitted or an empty string ("") is specified, all key names for the object are returned. |
||||||
blnAttachToGeometry |
Optional. Boolean. The location on the object to retrieve the User Text.
|
String |
If strKey is specified, then the associated value if successful. |
Array |
If strKey is not specified, then an array of key names if successful. |
Null |
If not successful, or on error. |
Dim strObject
strObject = Rhino.GetObject("Select object")
If VarType(strObject) = vbString Then
Rhino.Print Rhino.GetUserText(strObject, "PartNo")
Rhino.Print Rhino.GetUserText(strObject, "Price")
End If