GetLayers

Displays a dialog box prompting the user to select one or more layers.

Syntax

Rhino.GetLayers ([strTitle [, blnShowNewLayer]])

Parameters

strTitle

Optional.  String.  A dialog box title.

blnShowNewLayer

Optional.  Boolean.  Display the "New" layer button. If omitted, the button is not displayed.

Returns

Array

The names of the selected layers if successful.

Null

If not successful, or on error.

Example

Dim arrLayers, strLayer

arrLayers = Rhino.GetLayers("Select Layers")

If IsArray(arrLayers) Then

  For Each strLayer in arrLayers

    Call Rhino.Print(strLayer)

  Next

End If

Also See

GetLayer

GetLinetype

GetPrintWidth