GetPointOnLine

Pauses for user input of a point constrained to an infinite line.

Syntax

Rhino.GetPointOnLine (strMessage, arrStart, arrEnd [, blnTrack])

Parameters

strMessage

Required.  String.  A prompt or message.

arrStart

Required.  Array.  The starting point of the line.

arrEnd

Required.  Array.  The ending point of the line.

blnTrack

Optional.  Boolean.  Draw a tracking line from arrStart. If omitted, a tracking line is drawn (True).

Returns

Array

The 3-D point selected by the user if successful.

Null

If not successful, or on error.

Example

Dim arrPlane, arrStart, arrEnd, arrPt

arrPlane = Rhino.ViewCPlane

arrStart = arrPlane(0)

arrEnd = Rhino.PointAdd(arrPlane(0), arrPlane(3))

arrPt = Rhino.GetPointOnLine("Pick location", arrStart, arrEnd)

Also See

GetPoint

GetPoints