Home > RhinoScript Methods > View Methods > BackgroundBitmap
The BackgroundBitmap method is obsolete and will be phased out in the future. Use the AddPictureFrame method instead."
Returns or sets the background bitmap of the specified view. To remove a wallpaper bitmap, pass an empty string, or "", as the filename to display.
Rhino.BackgroundBitmap ([strView [, strFileName [, arrPoint [, dblWidth]]]])
strView |
Optional. String. The title or identifier of the view. If omitted, the current active view is used. |
||||||||||||||
|
Optional. String. The name of the bitmap file to set as the background bitmap. The supported bitmap file formats are as follows:
|
||||||||||||||
arrPoint |
Optional. Array. A 3-D point the lower left corner of the background bitmap. If omitted, the background bitmap's lower left corner will be located at the world origin, or (0,0,0). |
||||||||||||||
dblWidth |
Optional. Number. The width of the background bitmap. If omitted, the actual width of the bitmap will be used. |
String |
If strFileName is not specified, then the current background bitmap filename if successful. |
String |
If strFileName is specified, then the previous background bitmap filename if successful. |
Null |
If not successful, or on error. |
Dim strView
strView = Rhino.CurrentView
If Not Rhino.IsBackgroundBitmap(strView) Then
Rhino.BackgroundBitmap strView, "C:\Windows\Coffee Bean.bmp", Array(0,0,0), 25
End If