Returns or sets the camera location of the specified view.
Rhino.ViewCamera ([strView [, arrCamera]])
strView |
Optional. String. The title or identifier of the view. If omitted, the current active view is used. |
arrCamera |
Optional. Array. A 3-D point identifying the new camera location. If arrCamera is not specified, the current camera location is returned. |
Array |
If arrCamera is not specified, then a 3-D point containing the current camera location if successful. |
Array |
If arrCamera is specified, then a 3-D point containing the previous camera location if successful. |
Null |
If not successful, or on error. |
Dim strView, arrCamera
strView = Rhino.CurrentView
arrCamera = Rhino.GetPoint("Select new camera location")
If IsArray(arrCamera) Then
Rhino.ViewCamera strView, arrCamera
End If