ViewSpeedTest

Tests Rhino's display performance by regenerating a view a user-defined number of times. Note, this method is functionally equivalent to the TextMaxSpeed command.

Syntax

Rhino.ViewSpeedTest ([strView [, intFrames [, blnFreeze [, intDirection [, dblAngle]]]]])

Parameters

strView

Optional.  String.  The title or identifier of the view.  If omitted, the current active view is used.

intFrames

Optional.  String.  The number of frames, or times to regenerate the view. If omitted, the view will be regenerated 100 times.

blnFreeze

Optional.  String.  If True (Default), then Rhino's display list will not be updated with every frame redraw. If False, then Rhino's display list will be updated with every frame redraw.

intDirection

Optional. Number.  The direction to rotate the view, where 0 = Right, 1 = Left, 2 = Down, and 3 = Up. The default direction is Right (0).

dblAngle

Optional.  Number.  The angle to rotate. If omitted, the rotation angle of 5.0 degrees will be used.

Returns

Number

The number of seconds it took to regenerate the view intFrames number of times, if successful.

Null

If not successful, or on error.

Example

Dim strView, intFrames, dblSeconds

strView = "Perspective"

intFrames = 100

dblSeconds = Rhino.ViewSpeedTest(strView, 100)

If Not IsNull(dblSeconds) Then

  Rhino.Print "Time to regen viewport " & CStr(intFrames) & " times = " & CStr(dblSeconds) & " seconds."

End If