Rhino C++ API  8.7
Public Member Functions | List of all members
DisplayAttrsMgrList Class Reference

#include <RhinoSdkDisplayAttrsMgr.h>

Inheritance diagram for DisplayAttrsMgrList:
ON_ClassArray< DisplayAttrsMgrListDesc >

Public Member Functions

 DisplayAttrsMgrList ()
 
bool LoadProfile (const wchar_t *lpsSection, CRhinoProfileContext &)
 load from registry More...
 
void SaveProfile (const wchar_t *lpsSection, CRhinoProfileContext &) const
 
- Public Member Functions inherited from ON_ClassArray< DisplayAttrsMgrListDesc >
 ON_ClassArray () ON_NOEXCEPT
 construction //////////////////////////////////////////////////////// More...
 
 ON_ClassArray (const ON_ClassArray< DisplayAttrsMgrListDesc > &)
 Copy constructor. More...
 
 ON_ClassArray (size_t)
 size_t parameter = initial capacity More...
 
virtual ~ON_ClassArray ()
 override for struct member deallocation, etc. More...
 
void Append (const DisplayAttrsMgrListDesc &)
 
void Append (int, const DisplayAttrsMgrListDesc *)
 Append copy of an array T[count]. More...
 
DisplayAttrsMgrListDescAppendNew ()
 array operations //////////////////////////////////////////////////// More...
 
DisplayAttrsMgrListDescArray ()
 The Array() function return the. More...
 
const DisplayAttrsMgrListDescArray () const
 m_a pointer value. More...
 
DisplayAttrsMgrListDescAt (int)
 At(index) returns nullptr if index < 0 or index >= count. More...
 
const DisplayAttrsMgrListDescAt (int) const
 
DisplayAttrsMgrListDescAt (ON__INT64)
 
const DisplayAttrsMgrListDescAt (ON__INT64) const
 
DisplayAttrsMgrListDescAt (ON__UINT64)
 
const DisplayAttrsMgrListDescAt (ON__UINT64) const
 
DisplayAttrsMgrListDescAt (unsigned int)
 
const DisplayAttrsMgrListDescAt (unsigned int) const
 
int BinarySearch (const DisplayAttrsMgrListDesc *, int(*)(const DisplayAttrsMgrListDesc *, const DisplayAttrsMgrListDesc *)) const
 See Also: ON_CompareIncreasing<T> and ON_CompareDeccreasing<T> More...
 
int BinarySearch (const DisplayAttrsMgrListDesc *, int(*)(const DisplayAttrsMgrListDesc *, const DisplayAttrsMgrListDesc *), int) const
 
int Capacity () const
 capacity of array More...
 
int Count () const
 query /////////////////////////////////////////////////////////////// More...
 
void Destroy ()
 onfree any memory and set count and capacity to zero More...
 
void EmergencyDestroy (void)
 emergency bailout /////////////////////////////////////////////////// More...
 
void Empty ()
 Sets count to 0, leaves capacity untouched. More...
 
DisplayAttrsMgrListDescFirst ()
 
const DisplayAttrsMgrListDescFirst () const
 returns nullptr if count = 0 More...
 
virtual bool HeapSort (int(*)(const DisplayAttrsMgrListDesc *, const DisplayAttrsMgrListDesc *))
 QuickSort() is generally the better choice. More...
 
void Insert (int, const DisplayAttrsMgrListDesc &)
 Insert called with a reference uses operator =. More...
 
int InsertInSortedList (const DisplayAttrsMgrListDesc &, int(*)(const DisplayAttrsMgrListDesc *, const DisplayAttrsMgrListDesc *))
 
int InsertInSortedList (const DisplayAttrsMgrListDesc &, int(*)(const DisplayAttrsMgrListDesc *, const DisplayAttrsMgrListDesc *), int)
 
DisplayAttrsMgrListDescKeepArray ()
 
DisplayAttrsMgrListDescLast ()
 
const DisplayAttrsMgrListDescLast () const
 returns nullptr if count = 0 More...
 
int NewCapacity () const
 
 operator const DisplayAttrsMgrListDesc * () const
 
 operator DisplayAttrsMgrListDesc * ()
 The cast operators return a pointer. More...
 
ON_ClassArray< DisplayAttrsMgrListDesc > & operator= (const ON_ClassArray< DisplayAttrsMgrListDesc > &)
 Assignment operator. More...
 
DisplayAttrsMgrListDescoperator[] (int)
 
const DisplayAttrsMgrListDescoperator[] (int) const
 
DisplayAttrsMgrListDescoperator[] (ON__INT64)
 
const DisplayAttrsMgrListDescoperator[] (ON__INT64) const
 
DisplayAttrsMgrListDescoperator[] (ON__UINT64)
 
const DisplayAttrsMgrListDescoperator[] (ON__UINT64) const
 
DisplayAttrsMgrListDescoperator[] (unsigned int)
 
const DisplayAttrsMgrListDescoperator[] (unsigned int) const
 
bool Permute (const int *)
 
virtual bool QuickSort (int(*)(const DisplayAttrsMgrListDesc *, const DisplayAttrsMgrListDesc *))
 Sorts the array using the heap sort algorithm. More...
 
virtual DisplayAttrsMgrListDescRealloc (DisplayAttrsMgrListDesc *, int)
 low level memory management /////////////////////////////////////// More...
 
void Remove ()
 
void Remove (int)
 
DisplayAttrsMgrListDescReserve (size_t)
 memory management ///////////////////////////////////////////////// More...
 
void Reverse ()
 reverse order More...
 
int Search (const DisplayAttrsMgrListDesc *, int(*)(const DisplayAttrsMgrListDesc *, const DisplayAttrsMgrListDesc *)) const
 
void SetArray (DisplayAttrsMgrListDesc *)
 
void SetArray (DisplayAttrsMgrListDesc *, int, int)
 
DisplayAttrsMgrListDescSetCapacity (size_t)
 
void SetCount (int)
 low level memory management ////////////////////////////////////////// More...
 
void Shrink ()
 remove unused capacity More...
 
unsigned int SizeOfArray () const
 amount of memory in the m_a[] array More...
 
unsigned int SizeOfElement () const
 amount of memory in an m_a[] array element More...
 
bool Sort (ON::sort_algorithm sort_algorithm, int *, int(*)(const DisplayAttrsMgrListDesc *, const DisplayAttrsMgrListDesc *)) const
 
bool Sort (ON::sort_algorithm sort_algorithm, int *, int(*)(const DisplayAttrsMgrListDesc *, const DisplayAttrsMgrListDesc *, void *), void *) const
 
void Swap (int, int)
 swap elements i and j More...
 
unsigned int UnsignedCount () const
 
void Zero ()
 

Additional Inherited Members

- Protected Member Functions inherited from ON_ClassArray< DisplayAttrsMgrListDesc >
void ConstructDefaultElement (DisplayAttrsMgrListDesc *)
 
void DestroyElement (DisplayAttrsMgrListDesc &)
 
void Move (int, int, int)
 implementation ////////////////////////////////////////////////////// More...
 
- Protected Attributes inherited from ON_ClassArray< DisplayAttrsMgrListDesc >
DisplayAttrsMgrListDescm_a
 pointer to array memory More...
 
int m_capacity
 actual length of m_a[] More...
 
int m_count
 0 <= m_count <= m_capacity More...
 

Constructor & Destructor Documentation

◆ DisplayAttrsMgrList()

DisplayAttrsMgrList::DisplayAttrsMgrList ( )

Member Function Documentation

◆ LoadProfile()

bool DisplayAttrsMgrList::LoadProfile ( const wchar_t *  lpsSection,
CRhinoProfileContext  
)

load from registry

LoadProfile will zero the array out and build a new list with all the keys under lpsSection whos name can be converted to a valid UUID.

◆ SaveProfile()

void DisplayAttrsMgrList::SaveProfile ( const wchar_t *  lpsSection,
CRhinoProfileContext  
) const

save in registry