Rhino C++ API  8.6
Public Member Functions | Static Public Member Functions | Protected Member Functions | List of all members
IRhRdkContentUISection Class Referenceabstract

#include <IRhRdkSectionHolder.h>

Public Member Functions

virtual void * EVF (const wchar_t *wszFunc, void *pvData)=0
 
virtual bool GetSelection (OUT CRhRdkContentArray &aContent) const =0
 
virtual bool SetSelection (const CRhRdkContentArray &aContent)=0
 

Static Public Member Functions

static bool GetSelection (const IRhinoUiWithController &ui, OUT CRhRdkContentArray &aContent)
 
static bool SetSelection (const IRhinoUiWithController &ui, const CRhRdkContentArray &aContent)
 

Protected Member Functions

virtual ~IRhRdkContentUISection ()
 

Constructor & Destructor Documentation

◆ ~IRhRdkContentUISection()

virtual IRhRdkContentUISection::~IRhRdkContentUISection ( )
inlineprotectedvirtual

Member Function Documentation

◆ EVF()

virtual void* IRhRdkContentUISection::EVF ( const wchar_t *  wszFunc,
void *  pvData 
)
pure virtual

Emergency virtual function for future expansion.

◆ GetSelection() [1/2]

static bool IRhRdkContentUISection::GetSelection ( const IRhinoUiWithController ui,
OUT CRhRdkContentArray aContent 
)
static

◆ GetSelection() [2/2]

virtual bool IRhRdkContentUISection::GetSelection ( OUT CRhRdkContentArray aContent) const
pure virtual

Get the currently selected content.

◆ SetSelection() [1/2]

virtual bool IRhRdkContentUISection::SetSelection ( const CRhRdkContentArray aContent)
pure virtual

Set the content selection.

◆ SetSelection() [2/2]

static bool IRhRdkContentUISection::SetSelection ( const IRhinoUiWithController ui,
const CRhRdkContentArray aContent 
)
static