Rhino C++ API  8.6
Public Member Functions | Protected Member Functions | List of all members
IRhRdkCustomCurveGraphSectionCallback Class Referenceabstract

#include <RhRdkCurveGraph.h>

Public Member Functions

virtual void DeleteThis (void)=0
 
virtual void * EVF (const wchar_t *wszFunc, void *pvData)=0
 
virtual void GetGraphXML (ON_wString &sXML) const =0
 
virtual void OnGraphChanged (const ON_wString &sXML)=0
 
virtual IRhRdkCustomCurveCtrl::Styles Style (void) const =0
 

Protected Member Functions

virtual ~IRhRdkCustomCurveGraphSectionCallback ()
 

Detailed Description

IRhRdkCustomCurveGraphSectionCallback

This interface is OBSOLETE and has been replaced by IRhRdkCustomCurveGraphSectionSharedCallback.

DO NOT IMPLEMENT THIS INTERFACE. Implement IRhRdkCustomCurveGraphSectionSharedCallback instead.

The return type of CRhRdkCoreContent::CustomCurveGraphSectionCallback() is wrong; it is this obsolete interface. Until we can fix this properly with [SDK_UNFREEZE] you must use reinterpret_cast to return a new instance of your implementation of IRhRdkCustomCurveGraphSectionSharedCallback as IRhRdkCustomCurveGraphSectionCallback.

IRhRdkCustomCurveGraphSectionCallback* CMyMaterial::CustomCurveGraphSectionCallback(void) { return reinterpret_cast<IRhRdkCustomCurveGraphSectionCallback*>(new CMyCurveCallback); }

Constructor & Destructor Documentation

◆ ~IRhRdkCustomCurveGraphSectionCallback()

virtual IRhRdkCustomCurveGraphSectionCallback::~IRhRdkCustomCurveGraphSectionCallback ( )
inlineprotectedvirtual

Member Function Documentation

◆ DeleteThis()

virtual void IRhRdkCustomCurveGraphSectionCallback::DeleteThis ( void  )
pure virtual

◆ EVF()

virtual void* IRhRdkCustomCurveGraphSectionCallback::EVF ( const wchar_t *  wszFunc,
void *  pvData 
)
pure virtual

◆ GetGraphXML()

virtual void IRhRdkCustomCurveGraphSectionCallback::GetGraphXML ( ON_wString sXML) const
pure virtual

◆ OnGraphChanged()

virtual void IRhRdkCustomCurveGraphSectionCallback::OnGraphChanged ( const ON_wString sXML)
pure virtual

◆ Style()

virtual IRhRdkCustomCurveCtrl::Styles IRhRdkCustomCurveGraphSectionCallback::Style ( void  ) const
pure virtual