Rhino C++ API  8.7
Public Member Functions | Protected Member Functions | List of all members
IRhinoPageHost Class Referenceabstract

#include <RhinoSdkPages.h>

Inheritance diagram for IRhinoPageHost:
IRhinoOptionsPageHost IRhinoPropertiesPanelPageHost

Public Member Functions

virtual ~IRhinoPageHost ()=default
 
virtual void ChangeDefaultSize (ON_2iSize newSize)=0
 
virtual void Created ()=0
 
virtual unsigned int DocumentRuntimeSerialNumber () const =0
 
virtual IRhinoPagePage () const =0
 
virtual LPARAM PageHostProc (unsigned int message, WPARAM wParam, LPARAM lParam)
 
virtual void SizedChanged (ON_2iSize size)=0
 
virtual void VisibleChanged (bool visible)=0
 
virtual RHINO_WINDOW_HANDLE Window () const =0
 

Protected Member Functions

 IRhinoPageHost ()=default
 
 IRhinoPageHost (const IRhinoPageHost &)=delete
 
IRhinoPageHostoperator= (const IRhinoPageHost &)=delete
 

Detailed Description

class IRhinoPageHost

Description: Common host interface.

Constructor & Destructor Documentation

◆ ~IRhinoPageHost()

virtual IRhinoPageHost::~IRhinoPageHost ( )
virtualdefault

◆ IRhinoPageHost() [1/2]

IRhinoPageHost::IRhinoPageHost ( )
protecteddefault

Description: Default constructor.

◆ IRhinoPageHost() [2/2]

IRhinoPageHost::IRhinoPageHost ( const IRhinoPageHost )
protecteddelete

Description: Delete the default copy constructor

Member Function Documentation

◆ ChangeDefaultSize()

virtual void IRhinoPageHost::ChangeDefaultSize ( ON_2iSize  newSize)
pure virtual

Description: Call this method to update the original size for the page. This is useful when a page contains expandable sections that change the default page height. Changing this value will update the page host scroll bars if necessary.

◆ Created()

virtual void IRhinoPageHost::Created ( )
pure virtual

Description: Called when the native window has been created, tells the host it is time to create the page window.

◆ DocumentRuntimeSerialNumber()

virtual unsigned int IRhinoPageHost::DocumentRuntimeSerialNumber ( ) const
pure virtual

Description: The runtime serial number of the document associated with this page.

◆ operator=()

IRhinoPageHost& IRhinoPageHost::operator= ( const IRhinoPageHost )
protecteddelete

Description: Delete the default operator=

◆ Page()

virtual IRhinoPage* IRhinoPageHost::Page ( ) const
pure virtual

Description: The page this host is responsible for

◆ PageHostProc()

virtual LPARAM IRhinoPageHost::PageHostProc ( unsigned int  message,
WPARAM  wParam,
LPARAM  lParam 
)
virtual

Description: Reserved for future use to extend class without breaking the SDK

◆ SizedChanged()

virtual void IRhinoPageHost::SizedChanged ( ON_2iSize  size)
pure virtual

Description: Called when the native window size changes, tells the host it is time to resize the page.

◆ VisibleChanged()

virtual void IRhinoPageHost::VisibleChanged ( bool  visible)
pure virtual

Description: Called when the native window visibility state changes, the pages visibility state should be synchronized with the host.

◆ Window()

virtual RHINO_WINDOW_HANDLE IRhinoPageHost::Window ( ) const
pure virtual

Description: Return the native host window Returns: Return the native host window