Rhino C++ API  8.7
Public Member Functions | Static Public Member Functions | Public Attributes | Static Public Attributes | List of all members
ON_2dSize Class Reference

#include <opennurbs_point.h>

Public Member Functions

 ON_2dSize ()=default
 
 ON_2dSize (const ON_2dSize &)=default
 
 ON_2dSize (double cx, double cy)
 
 ~ON_2dSize ()=default
 
bool IsSet () const
 
bool IsZero () const
 
ON_2dSizeoperator= (const ON_2dSize &)=default
 

Static Public Member Functions

static int Compare (const ON_2dSize &lhs, const ON_2dSize &rhs)
 
static int ComparePointer (const ON_2dSize *lhs, const ON_2dSize *rhs)
 

Public Attributes

double cx
 
double cy
 

Static Public Attributes

static const ON_2dSize Unset
 (ON_UNSET_DOUBLE,ON_UNSET_DOUBLE) More...
 
static const ON_2dSize Zero
 (0.0,0.0) More...
 

Detailed Description

Class ON_2dSize

Constructor & Destructor Documentation

◆ ON_2dSize() [1/3]

ON_2dSize::ON_2dSize ( )
default

Default construction intentionally leaves x and y uninitialized. Use something like ON_2dSize pt(1.0,2.0); or ON_2dSize pt = ON_2dSize::Zero; when you need an initialized ON_2dSize.

◆ ~ON_2dSize()

ON_2dSize::~ON_2dSize ( )
default

◆ ON_2dSize() [2/3]

ON_2dSize::ON_2dSize ( const ON_2dSize )
default

◆ ON_2dSize() [3/3]

ON_2dSize::ON_2dSize ( double  cx,
double  cy 
)

Member Function Documentation

◆ Compare()

static int ON_2dSize::Compare ( const ON_2dSize lhs,
const ON_2dSize rhs 
)
static

Dictionary compare. Returns: -1: lhs < rhs 0: lsh == rsh +1: lhs > rhs

◆ ComparePointer()

static int ON_2dSize::ComparePointer ( const ON_2dSize lhs,
const ON_2dSize rhs 
)
static

Dictionary compare. Returns: -1: lhs < rhs 0: lsh == rsh +1: lhs > rhs

◆ IsSet()

bool ON_2dSize::IsSet ( ) const

Returns: true if neither cx nor cy are ON_UNSET_DOUBLE.

◆ IsZero()

bool ON_2dSize::IsZero ( ) const

Returns: true if both cx and cy are 0.0

◆ operator=()

ON_2dSize& ON_2dSize::operator= ( const ON_2dSize )
default

Member Data Documentation

◆ cx

double ON_2dSize::cx

◆ cy

double ON_2dSize::cy

◆ Unset

const ON_2dSize ON_2dSize::Unset
static

(ON_UNSET_DOUBLE,ON_UNSET_DOUBLE)

◆ Zero

const ON_2dSize ON_2dSize::Zero
static

(0.0,0.0)