Rhino C++ API  8.7
Public Member Functions | Public Attributes | Static Public Attributes | List of all members
ON_4dex Class Reference

quadruplet of integer indices. More...

#include <opennurbs_defines.h>

Public Member Functions

 ON_4dex ()=default
 
 ON_4dex (const ON_4dex &)=default
 
 ON_4dex (int i, int j, int k, int l)
 
 ~ON_4dex ()=default
 
ON_4dex AsIncreasing () const
 return a copy, where i is smaller or equal to j, j is smaller or equal to k, and k is smaller or equal to l More...
 
ON_4dex AsPairwiseIncreasing () const
 return a copy, where i is smaller or equal to k; if they are equal, j is smaller or equal to l More...
 
bool operator!= (const ON_4dex &src) const
 
ON_4dexoperator= (const ON_4dex &)=default
 
bool operator== (const ON_4dex &src) const
 
int & operator[] (int i)
 
int operator[] (int i) const
 

Public Attributes

int i
 do not initialize i, j, k, l for performance reasons More...
 
int j
 
int k
 
int l
 

Static Public Attributes

static const ON_4dex Unset
 (ON_UNSET_INT_INDEX, ON_UNSET_INT_INDEX, ON_UNSET_INT_INDEX, ON_UNSET_INT_INDEX); More...
 
static const ON_4dex Zero
 (0, 0, 0, 0) More...
 

Detailed Description

quadruplet of integer indices.

Constructor & Destructor Documentation

◆ ON_4dex() [1/3]

ON_4dex::ON_4dex ( )
default

◆ ~ON_4dex()

ON_4dex::~ON_4dex ( )
default

◆ ON_4dex() [2/3]

ON_4dex::ON_4dex ( const ON_4dex )
default

◆ ON_4dex() [3/3]

ON_4dex::ON_4dex ( int  i,
int  j,
int  k,
int  l 
)

Member Function Documentation

◆ AsIncreasing()

ON_4dex ON_4dex::AsIncreasing ( ) const

return a copy, where i is smaller or equal to j, j is smaller or equal to k, and k is smaller or equal to l

◆ AsPairwiseIncreasing()

ON_4dex ON_4dex::AsPairwiseIncreasing ( ) const

return a copy, where i is smaller or equal to k; if they are equal, j is smaller or equal to l

◆ operator!=()

bool ON_4dex::operator!= ( const ON_4dex src) const

◆ operator=()

ON_4dex& ON_4dex::operator= ( const ON_4dex )
default

◆ operator==()

bool ON_4dex::operator== ( const ON_4dex src) const

◆ operator[]() [1/2]

int& ON_4dex::operator[] ( int  i)

◆ operator[]() [2/2]

int ON_4dex::operator[] ( int  i) const

Member Data Documentation

◆ i

int ON_4dex::i

do not initialize i, j, k, l for performance reasons

◆ j

int ON_4dex::j

◆ k

int ON_4dex::k

◆ l

int ON_4dex::l

◆ Unset

const ON_4dex ON_4dex::Unset
static

(ON_UNSET_INT_INDEX, ON_UNSET_INT_INDEX, ON_UNSET_INT_INDEX, ON_UNSET_INT_INDEX);

◆ Zero

const ON_4dex ON_4dex::Zero
static

(0, 0, 0, 0)