Click or drag to resize

GH_IWriterCreateChunk Method (String, Int32)

Create a new child chunk with the specified name and index qualifier. If another chunk already exists with similar properties, an exception will be thrown.

Namespace:  GH_IO.Serialization
Assembly:  GH_IO (in GH_IO.dll)
Syntax
GH_IWriter CreateChunk(
	string chunk_name,
	int chunk_index
)

Parameters

chunk_name
Type: SystemString
Name of new child.
chunk_index
Type: SystemInt32
Index of new child.

Return Value

Type: GH_IWriter
Exceptions
ExceptionCondition
ArgumentException Thrown if the name+index coordinte is already occupied by another chunk.
See Also