Click or drag to resize

GH_Plane Constructor (Double, Double, Double, Double, Double, Double, Double, Double, Double)

Constructor.

Namespace:  GH_IO.Types
Assembly:  GH_IO (in GH_IO.dll)
Syntax
public GH_Plane(
	double Ox,
	double Oy,
	double Oz,
	double Xx,
	double Xy,
	double Xz,
	double Yx,
	double Yy,
	double Yz
)

Parameters

Ox
Type: SystemDouble
X coordinate of plane origin.
Oy
Type: SystemDouble
Y coordinate of plane origin.
Oz
Type: SystemDouble
Z coordinate of plane origin.
Xx
Type: SystemDouble
X component of plane x axis.
Xy
Type: SystemDouble
Y component of plane x axis.
Xz
Type: SystemDouble
Z component of plane x axis.
Yx
Type: SystemDouble
X component of plane y axis.
Yy
Type: SystemDouble
Y component of plane y axis.
Yz
Type: SystemDouble
Z component of plane y axis.
See Also