Click or drag to resize

GH_PaletteStyleCreateBrush Method

Create a fill brush. At low zoom levels the brush will be solid colour, at medium to high zoom levels the brush will have a gradient.

Namespace:  Grasshopper.GUI.Canvas
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public virtual Brush CreateBrush(
	RectangleF rec,
	float zoom
)

Parameters

rec
Type: System.DrawingRectangleF
Target rectangle of fill brush.
zoom
Type: SystemSingle
Zoom level of target graphics surface.

Return Value

Type: Brush
A brush object that can be used to fill a custom area.
See Also