Click or drag to resize

GH_GraphicsUtilOffsetColour Method (Color, Int32)

Add a fixed value to all the channels in a colour.

Namespace:  Grasshopper.GUI
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public static Color OffsetColour(
	Color col,
	int shift
)

Parameters

col
Type: System.DrawingColor
The colour to mutate.
shift
Type: SystemInt32
Offset value (-255 ~ +255).

Return Value

Type: Color
The offsetted colour.
Remarks
The alpha channel of the colour is not offset.
See Also