Click or drag to resize

GH_GraphicsUtilRenderColourIcon Method (Graphics, Rectangle, Color, Single)

Render a colour icon into a graphics context. A colour icon contains a black outer and white inner edge.

Namespace:  Grasshopper.GUI
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public static void RenderColourIcon(
	Graphics g,
	Rectangle rec,
	Color colour,
	float scale
)

Parameters

g
Type: System.DrawingGraphics
Graphics object to draw with.
rec
Type: System.DrawingRectangle
Rectangle describing icon dimensions.
colour
Type: System.DrawingColor
Colour for icon.
scale
Type: SystemSingle
Scale adjustment.
See Also