Click or drag to resize

GH_GraphicsUtilRenderObjectOverlay Method (Graphics, IGH_ObjectProxy, RectangleF)

Render all overlay icons for a specific object. Overlays aren't drawn when the zoom is less than 80%

Namespace:  Grasshopper.GUI
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public static void RenderObjectOverlay(
	Graphics graphics,
	IGH_ObjectProxy obj,
	RectangleF target
)

Parameters

graphics
Type: System.DrawingGraphics
Graphics object to draw with.
obj
Type: Grasshopper.KernelIGH_ObjectProxy
Proxy to draw overlay for.
target
Type: System.DrawingRectangleF
Destination area for overlay icons.
See Also