Click or drag to resize

GH_GraphicsUtilRenderUnscaledIcon Method (Graphics, Image, Int32, Int32, Double)

Note: This API is now obsolete.

Draws an image file at 1:1 scale centered on the given coordinates.

Namespace:  Grasshopper.GUI
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
[ObsoleteAttribute("This method is obsolete, use a RenderIcon() overload instead.")]
public static void RenderUnscaledIcon(
	Graphics g,
	Image icon,
	int cx,
	int cy,
	double fade
)

Parameters

g
Type: System.DrawingGraphics
Graphics object to draw with.
icon
Type: System.DrawingImage
Image to draw.
cx
Type: SystemInt32
X center of image in Graphics coordinate.
cy
Type: SystemInt32
Y center of image in Graphics coordinate.
fade
Type: SystemDouble
Alpha fading factor.
See Also