Click or drag to resize

GH_ComponentParamServerCreateDuplicate Method

Attempts to duplicate a parameter. Attributes will be ignored. Warning! The duplicate will have the same ID as the original!

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public static IGH_Param CreateDuplicate(
	IGH_Param original
)

Parameters

original
Type: Grasshopper.KernelIGH_Param
Parameter to duplicate.

Return Value

Type: IGH_Param
A dupicate of the original or null on failure.
See Also