Click or drag to resize

GH_ConvertToSHA_Hash Method (Stream)

Create a SHA hash. The hash algorithm is only guaranteed to yield the same results from within a unique application domain.

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public static Guid ToSHA_Hash(
	Stream data
)

Parameters

data
Type: System.IOStream
Data to hash.

Return Value

Type: Guid
A guid representing the (partial) SHA hash.
See Also