Click or drag to resize

GH_UpgradeUtilSwapComponents Method (IGH_Component, IGH_Component, Boolean)

Replace an existing component with a different one. All parameters (input and output) will be migrated.

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public static bool SwapComponents(
	IGH_Component oldComponent,
	IGH_Component newComponent,
	bool migrateParameters
)

Parameters

oldComponent
Type: Grasshopper.KernelIGH_Component
Component current in a GH_Document.
newComponent
Type: Grasshopper.KernelIGH_Component
Component to swap.
migrateParameters
Type: SystemBoolean
If true, all parameters will be moved from old to new.

Return Value

Type: Boolean
True on success, false on failure.
See Also