Click or drag to resize

VersionNumber Methods

The VersionNumber type exposes the following members.

Methods
  NameDescription
Public methodCompareTo(Object)
Compares the value of this instance to a specified VersionNumber value and returns an integer that indicates whether this instance is earlier than, the same as, or later than the specified VersionNumber value.
Public methodCompareTo(VersionNumber)
Compares the value of this instance to a specified VersionNumber value and returns an integer that indicates whether this instance is earlier than, the same as, or later than the specified VersionNumber value.
Public methodToString
Converts the value of the current VersionNumber object to its equivalent string representation major.minor.yyddd.hhmmb. (Overrides ValueType.ToString().)
(Overrides ValueTypeToString.)
Public methodToVersion
Convert this VersionNumber class to System.Version()
Public methodStatic memberTryParse(String, VersionNumber)
Converts the specified string representation of a version number to its VersionNumber equivalent and returns a value that indicates whether the conversion succeeded.
Public methodStatic memberTryParse(Version, VersionNumber)
Attempt so convert the System.Version representation of a version number to its VersionNumber equivalent and returns a value that indicates whether the conversion succeeded.
Top
See Also