Click or drag to resize

GH_TreeFilter Methods

The GH_TreeFilter type exposes the following members.

Methods
  NameDescription
Public methodStatic memberFindItemBrackets
Locate the two parenthesis that delineate the index segment of an Index Rule set.
Public methodStatic memberFindNextLevelChar
Find the next occurance of a char in a string that is level with the search start index.
Public methodStatic memberFindPathBrackets
Locate the two curly brackets that delineate the path segment of an Index Rule set.
Public methodStatic memberFindPrevLevelChar
Find the previous occurance of a char in a string that is level with the search start index.
Public methodStatic memberParsePattern
Parses a textual filter and returns an instance of the GH_TreeFilter. If the filter cannot be parsed an exception will be thrown.
Public methodStatic memberSplitStringWithExpressions
Split a string into segments using level-aware split. This method throws exceptions if the input string is not correctly formatted.
Top
See Also