Click or drag to resize

GH_DebugDescriptionWriter Methods

The GH_DebugDescriptionWriter type exposes the following members.

Methods
  NameDescription
Public methodCloseBlock
Close the current block and decrease the depth by 1.
Public methodCreateBlock
Begin a new block. This will increase the depth by 1. You must call CloseBlock() if you call this function.
Public methodCreateLog
Get a single string that represents the entire log so far.
Public methodWriteLine
Write a new blank line to the log.
Public methodWriteLine(String)
Write a new line to the log.
Public methodWriteLine(String, Object)
Write a new formatted line to the log.
Public methodWriteLogToFile
Write the log to a text file.
Top
See Also