Click or drag to resize

GH_UserObject Methods

The GH_UserObject type exposes the following members.

Methods
  NameDescription
Public methodClear
Destroy all data except the file path and the ID.
Public methodCreateDefaultPath
Set the Path field for this user object to the default. The default file name is derived from the Description.Name field. This method also ensures the UserObject directory exists.
Public methodInstantiateObject
Instantiate a new IGH_DocumentObject from this User Object.
Public methodReadFromFile
Force an update of the local data from the file. The Path field must be set for this to work.
Public methodSaveToFile
Save the current User Object state to a file. Any existing file will be overwritten.
Public methodSetDataFromObject
Set the Data field content of ths UserObject from a Document object instance.
Top
See Also