Click or drag to resize

GH_Vector Methods

The GH_Vector type exposes the following members.

Methods
  NameDescription
Public methodCastFrom
Remote to Local caster function. This stuff is complex, don't concern yourself with casting logic.
(Overrides GH_GooTCastFrom(Object).)
Public methodCastToT(T)
Local to Remote caster function. This stuff is complex, don't concern yourself with casting logic.
(Overrides GH_GooTCastToQ(Q).)
Public methodDuplicate
Create a duplicate of this vector.
(Overrides GH_GooTDuplicate.)
Public methodDuplicateVector
Create a duplicate of this vector.
Public methodEmitProxy
Returns a proxy that represents this vector. Do not call this function unless you're
(Overrides GH_GooTEmitProxy.)
Public methodRead (Overrides GH_GooTRead(GH_IReader).)
Public methodToString
Format the vector using default grasshopper formatting logic.
(Overrides GH_GooTToString.)
Public methodWrite (Overrides GH_GooTWrite(GH_IWriter).)
Top
See Also