Click or drag to resize

VersionNumber Properties

The VersionNumber type exposes the following members.

Properties
  NameDescription
Public propertyBuildBranch
Gets the build branch component of this instance.
Public propertyIsValid
True when all information in the VersionNumber has valid values.
Public propertyMajor
Gets the major version number component of this instance.
Public propertyStatic memberMaxMajorVersionNumber
The largest possible valid value of VersionNumber.MajorVersionNumber.
Public propertyStatic memberMaxMinorVersionNumber
The largest possible valid value of VersionNumber.MinorVersionNumber.
Public propertyStatic memberMaxValid
The largest possible valid VersionNumber.
Public propertyStatic memberMaxValidBuildBranch
Represents the largest possible valid value of VersionNumber.BuildBranch. This field is read-only.
Public propertyStatic memberMaxValidTime
The largest possible valid value of VersionNumber.Time. This field is read-only.
Public propertyStatic memberMinMajorVersionNumber
The smallest possible valid value of VersionNumber.MajorVersionNumber.
Public propertyStatic memberMinMinorVersionNumber
The smallest possible valid value of VersionNumber.MinorVersionNumber.
Public propertyMinor
Gets the minor version number component of this instance.
Public propertyStatic memberMinValid
The smallest possible valid VersionNumber.
Public propertyStatic memberMinValidBuildBranch
Represents the smallest possible valid value of VersionNumber.BuildBranch. This field is read-only.
Public propertyStatic memberMinValidTime
The smallest possible valid value of VersionNumber.Time. This field is read-only.
Public propertyTime
Gets the version time component of this instance.
Public propertyStatic memberUnset
The Unset VersionNumber. VersionNumber.Unset.IsValid is false.
Public propertyStatic memberUnsetBuildBranch
The value of an Unset VersionNumber.BuildBranch.
Public propertyStatic memberUnsetTime
The value of an Unset VersionNumber.Time.
Top
See Also