Click or drag to resize

GH_ColourPickerBase Properties

The GH_ColourPickerBase type exposes the following members.

Properties
  NameDescription
Public propertyAutoSize
Gets or sets a value indicating whether the width and height of the Bounds are adjusted to fit the UI.
Public propertyBackColour
Gets or sets the background colour of the picker.
Public propertyBaseColour
Gets the original base colour for this picker. Use SetupColourPicker to assign this colour.
Public propertyBounds
Gets or sets the Bounds for this control.
Public propertyColourSpace
Gets the Colour space mode used in this picker.
Public propertyDesiredHeight
Gets the ideal height for this colour picker given it's width and UI settings.
Public propertyDrawAlphaSlider
Gets or sets whether or not the alpha slider is included in the UI.
Public propertyDrawBackground
Gets or sets whether the background of the picker is drawn.
Public propertyDrawChannelSliders
Gets or sets whether or not the three basic channel sliders are included in the UI.
Public propertyDropperPreviewBox
Gets the rectangle in which the eye-dropped preview will be drawn.
Public propertyFont
Gets or sets the Font used in this Colour Picker. Do not Dispose the Font returned by this property.
Public propertyIsTextInput
Gets whether any of the slider is currently displaying a text input box.
Public propertyPadding
Gets or sets the Padding for this control.
Public propertyPickColour
Gets the picked colour.
Public propertySRCSpaceBox
Gets the rectangle containing the eye-dropper function.
Top
See Also