Click or drag to resize

GH_Canvas Properties

The GH_Canvas type exposes the following members.

Properties
  NameDescription
Public propertyActiveInteraction
Gets or sets the currently active interaction object.
Public propertyActiveObject
Gets or sets the currently active object.
Public propertyActiveWidget
Gets or sets the currently active widget.
Public propertyCursorCanvasPosition
Gets the location of the cursor in Canvas coordinates.
Public propertyCursorControlPosition
Gets the location of the cursor in Control coordinates.
Public propertyStatic memberDisplayVoronoiWarning
Gets or sets whether the Voronoi Over-dose warning message is displayed. This property is set once at Grasshopper startup to True.
Public propertyDocument
Gets or sets the document currently loaded in this canvas.
Public propertyDrawingMode
Gets the current drawing mode for this canvas.
Public propertyHasControlWithFocus
Gets whether or not this canvas has a child control on it with focus.
Public propertyIsActiveInteraction
Gets a value indicating whether or not there is an interaction object loaded in this canvas.
Public propertyIsActiveObject
Gets a value indicating whether or not an object is currently activated.
Public propertyIsActiveWidget
Gets a value indicating whether or not a widget is currently activated.
Public propertyIsDocument
Gets a value indicating whether or not a document is currently loaded in this canvas.
Public propertyMarkovSuggestions
Public propertyModifiersEnabled
Gets or sets the modifiers enabled flag. When modifiers are disabled, only zooming and panning is still allowed.
Public propertyStatic memberNavigationPanDown
Gets or sets the special key for panning down.
Public propertyStatic memberNavigationPanLeft
Gets or sets the special key for panning left.
Public propertyStatic memberNavigationPanPixels
Gets or sets the number of pixels for each pan operation.
Public propertyStatic memberNavigationPanRight
Gets or sets the special key for panning right.
Public propertyStatic memberNavigationPanUp
Gets or sets the special key for panning up.
Public propertyStatic memberNavigationZoomFactor
Gets or sets the zoom factor for navigation zoom operations.
Public propertyStatic memberNavigationZoomIn
Gets or sets the special key for zooming in.
Public propertyStatic memberNavigationZoomOut
Gets or sets the special key for zooming in.
Public propertyPainter
Gets the painter object that handles most of the drawing logic for this canvas.
Public propertyPainting
Gets whether this canvas is currently busy painting itself.
Public propertyRecordPreviewBoundary
Public propertyTagArtistIDs
Gets all the TagArtist IDs in this Canvas.
Public propertyStatic memberThumbnailSize
Gets the thumbnail size for documents.
Public propertyTooltipDelay
Gets the delay (in milliseconds) required for a tooltip popup. This delay is a user setting stored under the Canvas:TooltipDelay field of the core settings.
Public propertyValidator
Provides access to all the validators associated with this canvas.
Public propertyViewport
Gets the viewport that determines the panning and zooming for this canvas.
Public propertyWidgets
Gets a list of all the widgets on this canvas.
Public propertyStatic memberZoomFadeHigh
Gets the ZUI fade alpha value for the high zoom level threshold. This static field gets set on every Canvas paint start. The high threshold is typically used for ZUI elements that only appear when zoomed in.
Public propertyStatic memberZoomFadeLow
Gets the ZUI fade alpha value for the low zoom level threshold. This static field gets set on every Canvas paint start. The low threshold is typically used for fading of icons and object names.
Public propertyStatic memberZoomFadeMedium
Gets the ZUI fade alpha value for the medium zoom level threshold. This static field gets set on every Canvas paint start. The medium threshold is typically used for non-informative UI elements such as highlights.
Top
See Also