Click or drag to resize

GH_Slider Properties

The GH_Slider type exposes the following members.

Properties
  NameDescription
Public propertyControlEdgeColour
Gets or sets the EdgeColor for this slider control.
Public propertyControlShadowColour
Gets or sets the Shadow colour for this control.
Public propertyDecimalPlaces
Gets or sets the number of decimal places allowed for Floating Point Sliders.
Public propertyDrawControlBorder
Gets or sets whether the border of the slider should be drawn.
Public propertyDrawControlShadows
Gets or sets whether the drop shadows of the slider should be drawn.
Public propertyFormatMask
Gets or sets the string format mask to use for the display. Should contain at least one "{0}" element.
Public propertyGripBottomColour
Gets or sets the fill colour for the bottom edge of the slider grip.
Public propertyGripDisplay
Gets or sets how the slider grip (or thumb) is drawn.
Public propertyGripEdgeColour
Gets or sets the edge colour for the slider grip.
Public propertyGripTopColour
Gets or sets the fill colour for the top edge of the slider grip.
Public propertyMaximum
Gets or sets the upper numeric limit for the slider range.
Public propertyMinimum
Gets or sets the lower numeric limit for the slider range.
Public propertyRailBrightColour
Gets or sets the edge colour for the bright parts of the rail.
Public propertyRailDarkColour
Gets or sets the edge colour for the dark parts of the rail.
Public propertyRailDisplay
Gets or sets how the slider rail (or track) is drawn.
Public propertyRailEmptyColour
Gets or sets the fill colour for the empty portion of the rail.
Public propertyRailFullColour
Gets or sets the fill colour for the full portion of the rail.
Public propertyShadowSize
Gets or sets the size of the border shadow along all edges of the box.
Public propertyTextColour
Gets or sets the fill colour for the slider text.
Public propertyTickCount
Gets or sets the number of ticks.
Public propertyTickDisplay
Gets or sets how the slider ticks are drawn.
Public propertyTickFrequency
Gets or sets the frequency of large ticks vs small ticks.
Public propertyType
Gets or sets the numeric type of this slider.
Public propertyValue
Gets or sets the numeric value for the slider range.
Top
See Also