Click or drag to resize

GH_ResizeBorder Class

Inheritance Hierarchy

Namespace:  Grasshopper.GUI.Canvas
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public class GH_ResizeBorder : GH_Border

The GH_ResizeBorder type exposes the following members.

Constructors
  NameDescription
Public methodGH_ResizeBorder(GH_Border)
Create a new instance of the GH_ResizeBorder class.
Public methodGH_ResizeBorder(RectangleF, GH_BorderTopology)
Create a new instance of the GH_ResizeBorder class.
Top
Properties
  NameDescription
Public propertyAnchor
Gets or sets the anchor point for sizing operations. This point is determined automatically when you call Setup(), however you can alter it afterwards if you want.
Top
Methods
  NameDescription
Public methodSetup(IGH_Attributes, PointF)
Set up a new sizing operation.
Public methodSetup(IGH_Attributes, PointF, SizeF)
Set up a new sizing operation.
Public methodSetup(RectangleF, PointF, PointF)
Set up a new sizing operation.
Public methodSetup(IGH_Attributes, PointF, SizeF, SizeF)
Set up a new sizing operation.
Public methodSetup(RectangleF, PointF, PointF, SizeF)
Set up a new sizing operation.
Public methodSetup(RectangleF, PointF, PointF, SizeF, SizeF)
Set up a new sizing operation.
Public methodSolve
Solve a resizing step.
Top
See Also