Click or drag to resize

IGH_CanvasValidator Interface

'Interface used for limiting a collection of typical actions on the canvas. Do not implement this interface directly if you can help it, instead inherit from GH_CanvasValidator.

Namespace:  Grasshopper.GUI.Canvas
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public interface IGH_CanvasValidator

The IGH_CanvasValidator type exposes the following members.

Methods
  NameDescription
Public methodAddedToCanvas
This method will be called by the Canvas when this validator is added to it.
Public methodAppliesToDocument
Test whether this validator applies to a specific document.
Public methodCanAcceptObject
Validates whether a specific component can be accepted by the canvas at all.
Public methodCanCreateObject
Validates whether a specific component may be inserted at a specific point.
Public methodCanCreateWire
Validates whether a wire-operation can commence.
Public methodCanDeleteObject
Validates whether a specific object can be deleted.
Public methodCanDeleteWire
Validates whether a wire can be deleted.
Public methodCanDragObject
Validates whether some components can be dragged.
Public methodCanNavigateCanvas
Validates whether the canvas can be navigated (panning, zooming etc)
Public methodCanShowCanvasMenu
Validates whether the canvas menus (both the radial and the old-fashioned one) are allowed to pop up at a specific point.
Public methodCanShowComponentSearchBox
Validates whether the double-click-component-search-window is allowed to pop up at a specific point.
Public methodCanShowObjectMenu
Validates whether the object menu can be shown.
Public methodRemovedFromCanvas
This method will be called by the Canvas when this validator is removed from it.
Top
See Also