Click or drag to resize

GH_Culture Class

Represents a globally unique identifier. GH_Guid re-implements the framework System.Guid type.
Inheritance Hierarchy
SystemObject
  Grasshopper.Kernel.TypesGH_GooCultureInfo
    Grasshopper.Kernel.TypesGH_Culture

Namespace:  Grasshopper.Kernel.Types
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public class GH_Culture : GH_Goo<CultureInfo>

The GH_Culture type exposes the following members.

Constructors
  NameDescription
Public methodGH_Culture
Blank constructor
Public methodGH_Culture(CultureInfo)
Initializes a new instance of the GH_Culture class
Public methodGH_Culture(GH_Culture)
Initializes a new instance of the GH_Culture class
Top
Properties
Methods
  NameDescription
Public methodCastFrom (Overrides GH_GooTCastFrom(Object).)
Public methodCastToT(T) (Overrides GH_GooTCastToQ(Q).)
Public methodDuplicate (Overrides GH_GooTDuplicate.)
Public methodDuplicateCulture
Public methodEmitProxy (Overrides GH_GooTEmitProxy.)
Public methodRead (Overrides GH_GooTRead(GH_IReader).)
Public methodScriptVariable (Overrides GH_GooTScriptVariable.)
Public methodToString (Overrides GH_GooTToString.)
Public methodWrite (Overrides GH_GooTWrite(GH_IWriter).)
Top
Fields
See Also