Click or drag to resize

ModelView Class

Represents a 3D view frustum. Wraps the functionality of the ViewportInfo type.
Inheritance Hierarchy
SystemObject
  Grasshopper.Rhinoceros.DisplayModelView

Namespace:  Grasshopper.Rhinoceros.Display
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public sealed class ModelView : IGH_GeometricGoo, 
	IEquatable<ModelView>, IGH_PreviewData, IGH_BakeAwareData

The ModelView type exposes the following members.

Constructors
  NameDescription
Public methodModelView
Initializes a new instance of the ModelView class
Public methodModelView(Guid)
Create a new referenced view that references a RhinoView or NamedView object with the specified ref_guid.
Public methodModelView(ModelView)
Initializes a new instance of the ModelView class
Public methodModelView(RhinoView)
Initializes a new instance of the ModelView class
Public methodModelView(RhinoViewport)
Initializes a new instance of the ModelView class
Public methodModelView(ViewInfo)
Initializes a new instance of the ModelView class
Public methodModelView(ViewportInfo)
Initializes a new instance of the ModelView class
Public methodModelView(ViewportInfo, String)
Initializes a new instance of the ModelView class
Top
Properties
  NameDescription
Public propertyIsValid
Public propertyTitle
Top
Methods
See Also