Click or drag to resize

ModelUnitSystem Class

Represents a Rhino Unit System. Wraps the functionality of the UnitSystem type.
Inheritance Hierarchy

Namespace:  Grasshopper.Rhinoceros
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public sealed class ModelUnitSystem : ModelValue

The ModelUnitSystem type exposes the following members.

Constructors
  NameDescription
Public methodModelUnitSystem
Initializes a new instance of the ModelUnitSystem class
Public methodModelUnitSystem(ModelUnitSystemValue)
Initializes a new instance of the ModelUnitSystem class
Public methodModelUnitSystem(ActiveSpace, RhinoDoc)
Initializes a new instance of the ModelUnitSystem class
Top
Properties
  NameDescription
Public propertyActiveSpace
Public propertyBaseSystem
Public propertyFactor
Public propertyIsValid (Overrides ModelValue.IsValid.)
Public propertyMetersPerUnit
Public propertyName
Top
Methods
Operators
See Also