Rhino C++ API  8.6
Public Types | Public Member Functions | Protected Attributes | List of all members
CArgsRhinoGetArc Class Reference

#include <rhinoSdkGetArc.h>

Public Types

enum  eArcMode {
  center_start_end, center_start_angle, start_mid_end, start_end_mid,
  start_end_dir, start_dir_end, start_end_radius, tan_tan_tan,
  curve_end, center_mid_end, center_mid_angle
}
 current arc mode of GetArc functions More...
 

Public Member Functions

 CArgsRhinoGetArc ()
 
 CArgsRhinoGetArc (const CArgsRhinoGetArc &)
 
 ~CArgsRhinoGetArc ()
 
BOOL32 AcceptNumber () const
 
BOOL32 AllowDeformable () const
 
const double Angle () const
 
eArcMode ArcMode () const
 
const ON_wStringCenterPrompt () const
 
const double DefaultRadius () const
 
BOOL32 Deformable () const
 
int Degree () const
 
int Dir () const
 
const ON_wStringDirectionPrompt () const
 
const ON_wStringEndAnglePrompt () const
 
const ON_wStringEndPrompt () const
 
const ON_3dVectorNormal () const
 
CArgsRhinoGetArcoperator= (const CArgsRhinoGetArc &)
 
const ON_3dPointPoint1 () const
 
const ON_3dPointPoint2 () const
 
const ON_3dPointPoint3 () const
 
int PointCount () const
 
const ON_wStringPointOnArcPrompt () const
 
int Quadrant () const
 
const ON_wStringRadiusPrompt () const
 
void SetAcceptNumber (BOOL32=TRUE)
 Set whether the last prompt accepts a number or not. Used in center_start_end. More...
 
void SetAllowDeformable (BOOL32 b=TRUE)
 
void SetAngle (double)
 The current arc angle in center_start_angle. More...
 
void SetArcMode (eArcMode=start_end_mid)
 Set the arc mode. More...
 
void SetCenterPrompt (const wchar_t *)
 
void SetDefaultRadius (double)
 The default radius in start_end_radius. More...
 
void SetDeformable (BOOL32 bDeformable=TRUE)
 
void SetDegree (int degree)
 
void SetDir (int)
 The current arc direction in center_start_end. More...
 
void SetDirectionPrompt (const wchar_t *)
 
void SetEndAnglePrompt (const wchar_t *)
 
void SetEndPrompt (const wchar_t *)
 
void SetNormal (const ON_3dVector &)
 The current arc normal in center_start_end. More...
 
void SetPoint1 (const ON_3dPoint &)
 Set the first point to use instead of asking for one. More...
 
void SetPoint2 (const ON_3dPoint &)
 Set the second point to use instead of asking for one. More...
 
void SetPoint3 (const ON_3dPoint &)
 Set the third point to use instead of asking for one. More...
 
void SetPointCount (int count)
 
void SetPointOnArcPrompt (const wchar_t *)
 
void SetQuadrant (int)
 The current third point quadrant in center_start_end. More...
 
void SetRadiusPrompt (const wchar_t *)
 
void SetStartPrompt (const wchar_t *)
 
void SetUseActiveLayerLinetype (bool on)
 When true the linetype of the active layer is used for dynamic drawing. More...
 
void SetUsePoint3 (BOOL32=TRUE)
 
const ON_wStringStartPrompt () const
 
bool UseActiveLayerLinetype () const
 
BOOL32 UsePoint1 () const
 
BOOL32 UsePoint2 () const
 
BOOL32 UsePoint3 () const
 

Protected Attributes

BOOL32 m_allow_deformable
 
double m_angle
 [internal] the arc angle, used in center_start_angle More...
 
BOOL32 m_bAcceptNumber
 [i] if true, the last prompt accept number. Needed for center_start_end/angle More...
 
BOOL32 m_bUsePoint1
 [i] use m_point1 instead of asking for point More...
 
BOOL32 m_bUsePoint2
 [i] use m_point2 instead of asking for point More...
 
BOOL32 m_bUsePoint3
 [i] use m_point3 instead of asking for point More...
 
double m_dDefaultRadius
 [i/o] default radius for Start_End_Radius More...
 
BOOL32 m_deformable
 
int m_degree
 
int m_dir
 [internal] previous arc direction. Needed for center_start_end/angle More...
 
eArcMode m_mode
 [internal] Current mode while drawing the arc More...
 
ON_3dVector m_normal
 [i] the arc normal. Needed for center_start_end/angle More...
 
ON_3dPoint m_point1
 [i] if m_bHavePoint1 first point specified here More...
 
ON_3dPoint m_point2
 [i] if m_bHavePoint2 second point specified here More...
 
ON_3dPoint m_point3
 [i] if m_bHavePoint3 third point specified here More...
 
int m_point_count
 
int m_quadrant
 [internal] previous quadrant for last point. Needed for center_start_end/angle More...
 
ON_wString m_sCenterPrompt
 
ON_wString m_sDirectionPrompt
 
ON_wString m_sEndAnglePrompt
 
ON_wString m_sEndPrompt
 
ON_wString m_sPointOnArcPrompt
 
ON_wString m_sRadiusPrompt
 
ON_wString m_sStartPrompt
 

Detailed Description

Copyright (c) 1993-2017 Robert McNeel & Associates. All rights reserved. Rhinoceros is a registered trademark of Robert McNeel & Associates.

THIS SOFTWARE IS PROVIDED "AS IS" WITHOUT EXPRESS OR IMPLIED WARRANTY. ALL IMPLIED WARRANTIES OF FITNESS FOR ANY PARTICULAR PURPOSE AND OF MERCHANTABILITY ARE HEREBY DISCLAIMED.

For complete Rhino SDK copyright information see http://www.rhino3d.com/developer.


CLASS CArgsRhinoGetArc

OVERVIEW TEXT Arguments for GetArc... functions

KEYWORDS

Arc GetArc

Member Enumeration Documentation

◆ eArcMode

current arc mode of GetArc functions

Enumerator
center_start_end 
center_start_angle 
start_mid_end 
start_end_mid 
start_end_dir 
start_dir_end 
start_end_radius 
tan_tan_tan 
curve_end 
center_mid_end 
center_mid_angle 

Constructor & Destructor Documentation

◆ CArgsRhinoGetArc() [1/2]

CArgsRhinoGetArc::CArgsRhinoGetArc ( )

◆ ~CArgsRhinoGetArc()

CArgsRhinoGetArc::~CArgsRhinoGetArc ( )

◆ CArgsRhinoGetArc() [2/2]

CArgsRhinoGetArc::CArgsRhinoGetArc ( const CArgsRhinoGetArc )

Member Function Documentation

◆ AcceptNumber()

BOOL32 CArgsRhinoGetArc::AcceptNumber ( ) const

◆ AllowDeformable()

BOOL32 CArgsRhinoGetArc::AllowDeformable ( ) const

◆ Angle()

const double CArgsRhinoGetArc::Angle ( ) const

◆ ArcMode()

eArcMode CArgsRhinoGetArc::ArcMode ( ) const

◆ CenterPrompt()

const ON_wString& CArgsRhinoGetArc::CenterPrompt ( ) const

◆ DefaultRadius()

const double CArgsRhinoGetArc::DefaultRadius ( ) const

◆ Deformable()

BOOL32 CArgsRhinoGetArc::Deformable ( ) const

◆ Degree()

int CArgsRhinoGetArc::Degree ( ) const

◆ Dir()

int CArgsRhinoGetArc::Dir ( ) const

◆ DirectionPrompt()

const ON_wString& CArgsRhinoGetArc::DirectionPrompt ( ) const

◆ EndAnglePrompt()

const ON_wString& CArgsRhinoGetArc::EndAnglePrompt ( ) const

◆ EndPrompt()

const ON_wString& CArgsRhinoGetArc::EndPrompt ( ) const

◆ Normal()

const ON_3dVector& CArgsRhinoGetArc::Normal ( ) const

◆ operator=()

CArgsRhinoGetArc& CArgsRhinoGetArc::operator= ( const CArgsRhinoGetArc )

◆ Point1()

const ON_3dPoint& CArgsRhinoGetArc::Point1 ( ) const

◆ Point2()

const ON_3dPoint& CArgsRhinoGetArc::Point2 ( ) const

◆ Point3()

const ON_3dPoint& CArgsRhinoGetArc::Point3 ( ) const

◆ PointCount()

int CArgsRhinoGetArc::PointCount ( ) const

◆ PointOnArcPrompt()

const ON_wString& CArgsRhinoGetArc::PointOnArcPrompt ( ) const

◆ Quadrant()

int CArgsRhinoGetArc::Quadrant ( ) const

◆ RadiusPrompt()

const ON_wString& CArgsRhinoGetArc::RadiusPrompt ( ) const

◆ SetAcceptNumber()

void CArgsRhinoGetArc::SetAcceptNumber ( BOOL32  = TRUE)

Set whether the last prompt accepts a number or not. Used in center_start_end.

◆ SetAllowDeformable()

void CArgsRhinoGetArc::SetAllowDeformable ( BOOL32  b = TRUE)

◆ SetAngle()

void CArgsRhinoGetArc::SetAngle ( double  )

The current arc angle in center_start_angle.

◆ SetArcMode()

void CArgsRhinoGetArc::SetArcMode ( eArcMode  = start_end_mid)

Set the arc mode.

◆ SetCenterPrompt()

void CArgsRhinoGetArc::SetCenterPrompt ( const wchar_t *  )

◆ SetDefaultRadius()

void CArgsRhinoGetArc::SetDefaultRadius ( double  )

The default radius in start_end_radius.

◆ SetDeformable()

void CArgsRhinoGetArc::SetDeformable ( BOOL32  bDeformable = TRUE)

◆ SetDegree()

void CArgsRhinoGetArc::SetDegree ( int  degree)

◆ SetDir()

void CArgsRhinoGetArc::SetDir ( int  )

The current arc direction in center_start_end.

◆ SetDirectionPrompt()

void CArgsRhinoGetArc::SetDirectionPrompt ( const wchar_t *  )

◆ SetEndAnglePrompt()

void CArgsRhinoGetArc::SetEndAnglePrompt ( const wchar_t *  )

◆ SetEndPrompt()

void CArgsRhinoGetArc::SetEndPrompt ( const wchar_t *  )

◆ SetNormal()

void CArgsRhinoGetArc::SetNormal ( const ON_3dVector )

The current arc normal in center_start_end.

◆ SetPoint1()

void CArgsRhinoGetArc::SetPoint1 ( const ON_3dPoint )

Set the first point to use instead of asking for one.

◆ SetPoint2()

void CArgsRhinoGetArc::SetPoint2 ( const ON_3dPoint )

Set the second point to use instead of asking for one.

◆ SetPoint3()

void CArgsRhinoGetArc::SetPoint3 ( const ON_3dPoint )

Set the third point to use instead of asking for one.

◆ SetPointCount()

void CArgsRhinoGetArc::SetPointCount ( int  count)

◆ SetPointOnArcPrompt()

void CArgsRhinoGetArc::SetPointOnArcPrompt ( const wchar_t *  )

◆ SetQuadrant()

void CArgsRhinoGetArc::SetQuadrant ( int  )

The current third point quadrant in center_start_end.

◆ SetRadiusPrompt()

void CArgsRhinoGetArc::SetRadiusPrompt ( const wchar_t *  )

◆ SetStartPrompt()

void CArgsRhinoGetArc::SetStartPrompt ( const wchar_t *  )

◆ SetUseActiveLayerLinetype()

void CArgsRhinoGetArc::SetUseActiveLayerLinetype ( bool  on)

When true the linetype of the active layer is used for dynamic drawing.

◆ SetUsePoint3()

void CArgsRhinoGetArc::SetUsePoint3 ( BOOL32  = TRUE)

◆ StartPrompt()

const ON_wString& CArgsRhinoGetArc::StartPrompt ( ) const

◆ UseActiveLayerLinetype()

bool CArgsRhinoGetArc::UseActiveLayerLinetype ( ) const

◆ UsePoint1()

BOOL32 CArgsRhinoGetArc::UsePoint1 ( ) const

◆ UsePoint2()

BOOL32 CArgsRhinoGetArc::UsePoint2 ( ) const

◆ UsePoint3()

BOOL32 CArgsRhinoGetArc::UsePoint3 ( ) const

Member Data Documentation

◆ m_allow_deformable

BOOL32 CArgsRhinoGetArc::m_allow_deformable
protected

◆ m_angle

double CArgsRhinoGetArc::m_angle
protected

[internal] the arc angle, used in center_start_angle

◆ m_bAcceptNumber

BOOL32 CArgsRhinoGetArc::m_bAcceptNumber
protected

[i] if true, the last prompt accept number. Needed for center_start_end/angle

◆ m_bUsePoint1

BOOL32 CArgsRhinoGetArc::m_bUsePoint1
protected

[i] use m_point1 instead of asking for point

◆ m_bUsePoint2

BOOL32 CArgsRhinoGetArc::m_bUsePoint2
protected

[i] use m_point2 instead of asking for point

◆ m_bUsePoint3

BOOL32 CArgsRhinoGetArc::m_bUsePoint3
protected

[i] use m_point3 instead of asking for point

◆ m_dDefaultRadius

double CArgsRhinoGetArc::m_dDefaultRadius
protected

[i/o] default radius for Start_End_Radius

◆ m_deformable

BOOL32 CArgsRhinoGetArc::m_deformable
protected

◆ m_degree

int CArgsRhinoGetArc::m_degree
protected

◆ m_dir

int CArgsRhinoGetArc::m_dir
protected

[internal] previous arc direction. Needed for center_start_end/angle

◆ m_mode

eArcMode CArgsRhinoGetArc::m_mode
protected

[internal] Current mode while drawing the arc

◆ m_normal

ON_3dVector CArgsRhinoGetArc::m_normal
protected

[i] the arc normal. Needed for center_start_end/angle

◆ m_point1

ON_3dPoint CArgsRhinoGetArc::m_point1
protected

[i] if m_bHavePoint1 first point specified here

◆ m_point2

ON_3dPoint CArgsRhinoGetArc::m_point2
protected

[i] if m_bHavePoint2 second point specified here

◆ m_point3

ON_3dPoint CArgsRhinoGetArc::m_point3
protected

[i] if m_bHavePoint3 third point specified here

◆ m_point_count

int CArgsRhinoGetArc::m_point_count
protected

◆ m_quadrant

int CArgsRhinoGetArc::m_quadrant
protected

[internal] previous quadrant for last point. Needed for center_start_end/angle

◆ m_sCenterPrompt

ON_wString CArgsRhinoGetArc::m_sCenterPrompt
protected

◆ m_sDirectionPrompt

ON_wString CArgsRhinoGetArc::m_sDirectionPrompt
protected

◆ m_sEndAnglePrompt

ON_wString CArgsRhinoGetArc::m_sEndAnglePrompt
protected

◆ m_sEndPrompt

ON_wString CArgsRhinoGetArc::m_sEndPrompt
protected

◆ m_sPointOnArcPrompt

ON_wString CArgsRhinoGetArc::m_sPointOnArcPrompt
protected

◆ m_sRadiusPrompt

ON_wString CArgsRhinoGetArc::m_sRadiusPrompt
protected

◆ m_sStartPrompt

ON_wString CArgsRhinoGetArc::m_sStartPrompt
protected