Rhino C++ API
8.13
|
#include <rhinoSdkGetParabola.h>
Copyright (c) 1993-2017 Robert McNeel & Associates. All rights reserved. Rhinoceros is a registered trademark of Robert McNeel & Associates.
THIS SOFTWARE IS PROVIDED "AS IS" WITHOUT EXPRESS OR IMPLIED WARRANTY. ALL IMPLIED WARRANTIES OF FITNESS FOR ANY PARTICULAR PURPOSE AND OF MERCHANTABILITY ARE HEREBY DISCLAIMED.
For complete Rhino SDK copyright information see http://www.rhino3d.com/developer. Todo - make this puppy work, and when done separate the Get-part and add to SDK SDK header stuff, goes to rhinoSdkGetParabola.h
CLASS CArgsRhinoGetParabola
OVERVIEW TEXT Arguments for RhinoGetParabola... functions
KEYWORDS
CArgsRhinoGetParabola::CArgsRhinoGetParabola | ( | ) |
CArgsRhinoGetParabola::~CArgsRhinoGetParabola | ( | ) |
CArgsRhinoGetParabola::CArgsRhinoGetParabola | ( | const CArgsRhinoGetParabola & | ) |
const BOOL32 CArgsRhinoGetParabola::CapMode | ( | ) | const |
const ON_3dVector CArgsRhinoGetParabola::Direction | ( | ) | const |
const ON_wString& CArgsRhinoGetParabola::DirectionPrompt | ( | ) | const |
const ON_3dPoint CArgsRhinoGetParabola::EndPoint | ( | ) | const |
const ON_wString& CArgsRhinoGetParabola::EndPrompt | ( | ) | const |
const ON_3dPoint CArgsRhinoGetParabola::FocusPoint | ( | ) | const |
const ON_wString& CArgsRhinoGetParabola::FocusPrompt | ( | ) | const |
const BOOL32 CArgsRhinoGetParabola::HalfMode | ( | ) | const |
const BOOL32 CArgsRhinoGetParabola::MarkFocus | ( | ) | const |
CArgsRhinoGetParabola& CArgsRhinoGetParabola::operator= | ( | const CArgsRhinoGetParabola & | ) |
void CArgsRhinoGetParabola::SetCapMode | ( | BOOL32 | = TRUE | ) |
void CArgsRhinoGetParabola::SetDirection | ( | const ON_3dVector & | ) |
void CArgsRhinoGetParabola::SetDirectionPrompt | ( | const wchar_t * | ) |
void CArgsRhinoGetParabola::SetEndPoint | ( | const ON_3dPoint & | ) |
void CArgsRhinoGetParabola::SetEndPrompt | ( | const wchar_t * | ) |
void CArgsRhinoGetParabola::SetFocusPoint | ( | const ON_3dPoint & | ) |
void CArgsRhinoGetParabola::SetFocusPrompt | ( | const wchar_t * | ) |
void CArgsRhinoGetParabola::SetHalfMode | ( | BOOL32 | = TRUE | ) |
void CArgsRhinoGetParabola::SetMarkFocus | ( | BOOL32 | = TRUE | ) |
void CArgsRhinoGetParabola::SetSurfaceMode | ( | BOOL32 | = TRUE | ) |
void CArgsRhinoGetParabola::SetUseActiveLayerLinetype | ( | bool | on | ) |
When true the linetype of the active layer is used for dynamic drawing.
void CArgsRhinoGetParabola::SetVertexMode | ( | BOOL32 | = TRUE | ) |
void CArgsRhinoGetParabola::SetVertexPoint | ( | const ON_3dPoint & | ) |
void CArgsRhinoGetParabola::SetVertexPrompt | ( | const wchar_t * | ) |
sets
const BOOL32 CArgsRhinoGetParabola::SurfaceMode | ( | ) | const |
bool CArgsRhinoGetParabola::UseActiveLayerLinetype | ( | ) | const |
const BOOL32 CArgsRhinoGetParabola::VertexMode | ( | ) | const |
const ON_3dPoint CArgsRhinoGetParabola::VertexPoint | ( | ) | const |
const ON_wString& CArgsRhinoGetParabola::VertexPrompt | ( | ) | const |
gets
|
protected |
|
protected |
|
protected |
|
protected |
|
protected |
|
protected |
|
protected |
|
protected |
|
protected |
|
protected |
|
protected |
|
protected |
|
protected |