Rhino C++ API
8.13
|
#include <rhinoSdkGetSpiral.h>
Public Attributes | |
double | m_Pitch |
BOOL32 | m_PitchMode |
double | m_PointsPerTurn |
BOOL32 | m_ReverseTwist |
double | m_Turns |
Copyright (c) 1993-2017 Robert McNeel & Associates. All rights reserved. Rhinoceros is a registered trademark of Robert McNeel & Associates.
THIS SOFTWARE IS PROVIDED "AS IS" WITHOUT EXPRESS OR IMPLIED WARRANTY. ALL IMPLIED WARRANTIES OF FITNESS FOR ANY PARTICULAR PURPOSE AND OF MERCHANTABILITY ARE HEREBY DISCLAIMED.
For complete Rhino SDK copyright information see http://www.rhino3d.com/developer.
CLASS CArgsRhinoGetSpiral
OVERVIEW TEXT Arguments for RhinoGetHelix and RhinoGetSpiral
KEYWORDS
CArgsRhinoGetSpiral::CArgsRhinoGetSpiral | ( | ) |
CArgsRhinoGetSpiral::~CArgsRhinoGetSpiral | ( | ) |
CArgsRhinoGetSpiral::CArgsRhinoGetSpiral | ( | const CArgsRhinoGetSpiral & | ) |
const BOOL32 CArgsRhinoGetSpiral::AroundCurve | ( | ) | const |
const ON_wString& CArgsRhinoGetSpiral::CenterPrompt | ( | ) | const |
const BOOL32 CArgsRhinoGetSpiral::DiameterMode | ( | ) | const |
const ON_wString& CArgsRhinoGetSpiral::DiameterPrompt | ( | ) | const |
const ON_3dVector& CArgsRhinoGetSpiral::EndDir | ( | ) | const |
const ON_3dPoint& CArgsRhinoGetSpiral::EndPoint | ( | ) | const |
const ON_wString& CArgsRhinoGetSpiral::EndPrompt | ( | ) | const |
const ON_wString& CArgsRhinoGetSpiral::FirstDiameterPrompt | ( | ) | const |
const double CArgsRhinoGetSpiral::FirstRadius | ( | ) | const |
const ON_wString& CArgsRhinoGetSpiral::FirstRadiusPrompt | ( | ) | const |
const BOOL32 CArgsRhinoGetSpiral::Flat | ( | ) | const |
const BOOL32 CArgsRhinoGetSpiral::HelixMode | ( | ) | const |
const double CArgsRhinoGetSpiral::Length | ( | ) | const |
CArgsRhinoGetSpiral& CArgsRhinoGetSpiral::operator= | ( | const CArgsRhinoGetSpiral & | ) |
const double CArgsRhinoGetSpiral::Pitch | ( | ) | const |
const BOOL32 CArgsRhinoGetSpiral::PitchMode | ( | ) | const |
const double CArgsRhinoGetSpiral::PointsPerTurn | ( | ) | const |
const ON_3dPoint& CArgsRhinoGetSpiral::RadiusPoint | ( | ) | const |
const ON_wString& CArgsRhinoGetSpiral::RadiusPrompt | ( | ) | const |
ON_Curve* CArgsRhinoGetSpiral::Rail | ( | ) | const |
const BOOL32 CArgsRhinoGetSpiral::ReverseTwist | ( | ) | const |
const ON_wString& CArgsRhinoGetSpiral::SecondDiameterPrompt | ( | ) | const |
const double CArgsRhinoGetSpiral::SecondRadius | ( | ) | const |
const ON_wString& CArgsRhinoGetSpiral::SecondRadiusPrompt | ( | ) | const |
void CArgsRhinoGetSpiral::SetAroundCurve | ( | BOOL32 | ) |
void CArgsRhinoGetSpiral::SetCenterPrompt | ( | const wchar_t * | ) |
void CArgsRhinoGetSpiral::SetDiameterMode | ( | BOOL32 | ) |
void CArgsRhinoGetSpiral::SetDiameterPrompt | ( | const wchar_t * | ) |
void CArgsRhinoGetSpiral::SetEndDir | ( | const ON_3dVector & | ) |
void CArgsRhinoGetSpiral::SetEndPoint | ( | const ON_3dPoint & | ) |
void CArgsRhinoGetSpiral::SetEndPrompt | ( | const wchar_t * | ) |
void CArgsRhinoGetSpiral::SetFirstDiameterPrompt | ( | const wchar_t * | ) |
void CArgsRhinoGetSpiral::SetFirstRadius | ( | double | ) |
void CArgsRhinoGetSpiral::SetFirstRadiusPrompt | ( | const wchar_t * | ) |
void CArgsRhinoGetSpiral::SetFlat | ( | BOOL32 | ) |
void CArgsRhinoGetSpiral::SetHelixMode | ( | BOOL32 | ) |
void CArgsRhinoGetSpiral::SetLength | ( | double | ) |
void CArgsRhinoGetSpiral::SetPitch | ( | double | ) |
void CArgsRhinoGetSpiral::SetPitchMode | ( | BOOL32 | ) |
void CArgsRhinoGetSpiral::SetPointsPerTurn | ( | double | ) |
void CArgsRhinoGetSpiral::SetRadiusPoint | ( | const ON_3dPoint & | ) |
void CArgsRhinoGetSpiral::SetRadiusPrompt | ( | const wchar_t * | ) |
void CArgsRhinoGetSpiral::SetRail | ( | const ON_Curve * | ) |
void CArgsRhinoGetSpiral::SetReverseTwist | ( | BOOL32 | ) |
void CArgsRhinoGetSpiral::SetSecondDiameterPrompt | ( | const wchar_t * | ) |
void CArgsRhinoGetSpiral::SetSecondRadius | ( | double | ) |
void CArgsRhinoGetSpiral::SetSecondRadiusPrompt | ( | const wchar_t * | ) |
void CArgsRhinoGetSpiral::SetStartDir | ( | const ON_3dVector & | ) |
void CArgsRhinoGetSpiral::SetStartPoint | ( | const ON_3dPoint & | ) |
void CArgsRhinoGetSpiral::SetStartPrompt | ( | const wchar_t * | ) |
sets
void CArgsRhinoGetSpiral::SetToleranceWarning | ( | BOOL32 | ) |
void CArgsRhinoGetSpiral::SetTurns | ( | double | ) |
void CArgsRhinoGetSpiral::SetVertical | ( | BOOL32 | ) |
const ON_3dVector& CArgsRhinoGetSpiral::StartDir | ( | ) | const |
const ON_3dPoint& CArgsRhinoGetSpiral::StartPoint | ( | ) | const |
const ON_wString& CArgsRhinoGetSpiral::StartPrompt | ( | ) | const |
gets
const BOOL32 CArgsRhinoGetSpiral::ToleranceWarning | ( | ) | const |
const double CArgsRhinoGetSpiral::Turns | ( | ) | const |
const BOOL32 CArgsRhinoGetSpiral::Vertical | ( | ) | const |
|
protected |
|
protected |
|
protected |
|
protected |
|
protected |
|
protected |
|
protected |
|
protected |
|
protected |
|
protected |
|
protected |
|
protected |
|
protected |
double CArgsRhinoGetSpiral::m_Pitch |
BOOL32 CArgsRhinoGetSpiral::m_PitchMode |
double CArgsRhinoGetSpiral::m_PointsPerTurn |
|
protected |
|
protected |
|
protected |
BOOL32 CArgsRhinoGetSpiral::m_ReverseTwist |
|
protected |
|
protected |
|
protected |
|
protected |
|
protected |
|
protected |
|
protected |
double CArgsRhinoGetSpiral::m_Turns |
|
protected |