Rhino C++ API  8.6
Public Member Functions | Public Attributes | List of all members
CArgsRhinoPrintExportDlg Class Reference

#include <rhinoSdkPrintDialog.h>

Public Member Functions

 CArgsRhinoPrintExportDlg ()=default
 

Public Attributes

UINT m_custom_page_id = 0
 
ON_wString m_custom_page_title
 
bool m_display_page_margins = true
 
bool m_display_page_objectscale = true
 
bool m_display_page_show = true
 
bool m_display_page_viewscale = true
 
bool m_display_resolution_controls = true
 
bool m_force_vector = false
 dialog should show previews using GDI More...
 
int m_mode = -1
 
CRuntimeClass * m_pCustomPageClass = nullptr
 
AFX_MODULE_STATE * m_pCustomPageMS = nullptr
 

Detailed Description

Copyright (c) 1993-2017 Robert McNeel & Associates. All rights reserved. Rhinoceros is a registered trademark of Robert McNeel & Associates.

THIS SOFTWARE IS PROVIDED "AS IS" WITHOUT EXPRESS OR IMPLIED WARRANTY. ALL IMPLIED WARRANTIES OF FITNESS FOR ANY PARTICULAR PURPOSE AND OF MERCHANTABILITY ARE HEREBY DISCLAIMED.

For complete Rhino SDK copyright information see http://www.rhino3d.com/developer.

Constructor & Destructor Documentation

◆ CArgsRhinoPrintExportDlg()

CArgsRhinoPrintExportDlg::CArgsRhinoPrintExportDlg ( )
default

Member Data Documentation

◆ m_custom_page_id

UINT CArgsRhinoPrintExportDlg::m_custom_page_id = 0

◆ m_custom_page_title

ON_wString CArgsRhinoPrintExportDlg::m_custom_page_title

◆ m_display_page_margins

bool CArgsRhinoPrintExportDlg::m_display_page_margins = true

◆ m_display_page_objectscale

bool CArgsRhinoPrintExportDlg::m_display_page_objectscale = true

◆ m_display_page_show

bool CArgsRhinoPrintExportDlg::m_display_page_show = true

◆ m_display_page_viewscale

bool CArgsRhinoPrintExportDlg::m_display_page_viewscale = true

◆ m_display_resolution_controls

bool CArgsRhinoPrintExportDlg::m_display_resolution_controls = true

◆ m_force_vector

bool CArgsRhinoPrintExportDlg::m_force_vector = false

dialog should show previews using GDI

◆ m_mode

int CArgsRhinoPrintExportDlg::m_mode = -1

purpose: reason the print dialog is being displayed info: initial print info settings for dialog mode: 0 = single page 1 = multi-page 2 = all pages -1 = single page with no multi-page controls

◆ m_pCustomPageClass

CRuntimeClass* CArgsRhinoPrintExportDlg::m_pCustomPageClass = nullptr

◆ m_pCustomPageMS

AFX_MODULE_STATE* CArgsRhinoPrintExportDlg::m_pCustomPageMS = nullptr