#include <rhinoSdkGetRevolve.h>
◆ CArgsRhinoRailRevolve()
CArgsRhinoRailRevolve::CArgsRhinoRailRevolve |
( |
| ) |
|
◆ ~CArgsRhinoRailRevolve()
CArgsRhinoRailRevolve::~CArgsRhinoRailRevolve |
( |
| ) |
|
◆ Axis()
ON_Line CArgsRhinoRailRevolve::Axis |
( |
| ) |
const |
◆ AxisEndPrompt()
const wchar_t* CArgsRhinoRailRevolve::AxisEndPrompt |
( |
| ) |
const |
◆ AxisStartPrompt()
const wchar_t* CArgsRhinoRailRevolve::AxisStartPrompt |
( |
| ) |
const |
Description: Set or Get the prompt for revolve axis Parameters: prompt [in] the new prompt Returns: The current prompt
◆ ProfileCurve()
const ON_Curve* CArgsRhinoRailRevolve::ProfileCurve |
( |
| ) |
const |
Description: Get profile curve Returns: profile_curve
◆ ProfileObject()
const CRhinoObjRef& CArgsRhinoRailRevolve::ProfileObject |
( |
| ) |
const |
Description: Get profile curve object Returns: profile_object.
◆ ProfilePrompt()
const wchar_t* CArgsRhinoRailRevolve::ProfilePrompt |
( |
| ) |
const |
◆ RailCurve()
const ON_Curve* CArgsRhinoRailRevolve::RailCurve |
( |
| ) |
const |
◆ RailObject()
const CRhinoObjRef& CArgsRhinoRailRevolve::RailObject |
( |
| ) |
const |
◆ RailPrompt()
const wchar_t* CArgsRhinoRailRevolve::RailPrompt |
( |
| ) |
const |
Description: Set or Get the prompt for rail curve Parameters: prompt [in] the new prompt Returns: The current prompt
◆ ScaleHeight()
bool CArgsRhinoRailRevolve::ScaleHeight |
( |
| ) |
const |
◆ SetAxis()
void CArgsRhinoRailRevolve::SetAxis |
( |
ON_Line |
axis | ) |
|
Description: Set or get the revolve axis Parameters: axis [in] - a line on the axis Returns: a line on the axis
◆ SetAxisEndPrompt()
void CArgsRhinoRailRevolve::SetAxisEndPrompt |
( |
const wchar_t * |
prompt | ) |
|
◆ SetAxisStartPrompt()
void CArgsRhinoRailRevolve::SetAxisStartPrompt |
( |
const wchar_t * |
prompt | ) |
|
◆ SetProfileCurve()
void CArgsRhinoRailRevolve::SetProfileCurve |
( |
const ON_Curve * |
profile_curve | ) |
|
Description: Set profile curve Parameters: profile_curve [in] - profile curve. Remarks: ~CArgsRhinoRailRevolve does not delete this curve.
◆ SetProfileObject()
void CArgsRhinoRailRevolve::SetProfileObject |
( |
const CRhinoObjRef & |
profile_or | ) |
|
Description: Set profile curve Parameters: profile_or [in] - profile_or.Curve() is used as the profile.
◆ SetProfilePrompt()
void CArgsRhinoRailRevolve::SetProfilePrompt |
( |
const wchar_t * |
prompt | ) |
|
◆ SetRail()
void CArgsRhinoRailRevolve::SetRail |
( |
const ON_Curve * |
pCrv | ) |
|
Description: Set or get a pointer to the rail curve Parameters: rail_curve [in] - rail curve to save Returns: pointer to the rail curve
◆ SetRailCurve()
void CArgsRhinoRailRevolve::SetRailCurve |
( |
const ON_Curve * |
rail_curve | ) |
|
◆ SetRailObject()
void CArgsRhinoRailRevolve::SetRailObject |
( |
const CRhinoObjRef & |
rail_object | ) |
|
◆ SetRailPrompt()
void CArgsRhinoRailRevolve::SetRailPrompt |
( |
const wchar_t * |
prompt | ) |
|
◆ SetScaleHeight()
void CArgsRhinoRailRevolve::SetScaleHeight |
( |
bool |
scale | ) |
|
Description: Set or get whether or not hight of input profiles should scaled. Parameters: scale [in] - true: scale profile, false: don't scale Returns: @untitled table true Scale profile false Don't scale profile
◆ m_axis
ON_Line CArgsRhinoRailRevolve::m_axis |
|
protected |
◆ m_axis_end_prompt
ON_wString CArgsRhinoRailRevolve::m_axis_end_prompt |
|
protected |
◆ m_axis_start_prompt
ON_wString CArgsRhinoRailRevolve::m_axis_start_prompt |
|
protected |
◆ m_bScaleHeight
bool CArgsRhinoRailRevolve::m_bScaleHeight |
|
protected |
◆ m_profile_curve
const ON_Curve* CArgsRhinoRailRevolve::m_profile_curve |
|
protected |
◆ m_profile_object
◆ m_profile_prompt
ON_wString CArgsRhinoRailRevolve::m_profile_prompt |
|
protected |
◆ m_rail_curve
const ON_Curve* CArgsRhinoRailRevolve::m_rail_curve |
|
protected |
◆ m_rail_object
◆ m_rail_prompt