Rhino C++ API
8.13
|
#include <RhRdkDocument.h>
Public Member Functions | |
CRhRdkNewUndoableEvent (const CRhRdkCustomContentUI &ccui, const wchar_t *undo_string) | |
CRhRdkNewUndoableEvent (const IRhinoUiDataSource &h, const wchar_t *undo_string) | |
CRhRdkNewUndoableEvent (const IRhinoUiDataSourceHost &h, const wchar_t *undo_string) | |
CRhRdkNewUndoableEvent (const IRhinoUiDataSourceHost *pHost, const wchar_t *undo_string) | |
virtual | ~CRhRdkNewUndoableEvent () |
Public Member Functions inherited from CRhRdkObject | |
CRhRdkObject () | |
virtual | ~CRhRdkObject () |
virtual void * | EVF (const wchar_t *wszFunc, void *pvData) |
void | operator delete (void *buf) |
void | operator delete[] (void *buf) |
void * | operator new (size_t size) |
void * | operator new[] (size_t size) |
Additional Inherited Members | |
Static Public Member Functions inherited from CRhRdkObject | |
static void | CheckMemory (void) |
static void | PopulateDebuggingInfo (void) |
The new version of the undoable event was intended for use with the data source system which in the end did not belong in the public SDK. We still use it internally, and the use by the custom content UI could still be useful for 3rd-party plug-ins.
Note for RDK developers: this is not actually used by the RDK Eto UI. Instead, the UI uses the underlying data source directly via IRhRdkUndo.
CRhRdkNewUndoableEvent::CRhRdkNewUndoableEvent | ( | const IRhinoUiDataSource & | h, |
const wchar_t * | undo_string | ||
) |
CRhRdkNewUndoableEvent::CRhRdkNewUndoableEvent | ( | const IRhinoUiDataSourceHost & | h, |
const wchar_t * | undo_string | ||
) |
CRhRdkNewUndoableEvent::CRhRdkNewUndoableEvent | ( | const CRhRdkCustomContentUI & | ccui, |
const wchar_t * | undo_string | ||
) |
Construct using a custom content UI.
CRhRdkNewUndoableEvent::CRhRdkNewUndoableEvent | ( | const IRhinoUiDataSourceHost * | pHost, |
const wchar_t * | undo_string | ||
) |
|
virtual |