Rhino C++ API
8.13
|
#include <RhRdkPostEffectPlugInFactory.h>
Public Member Functions | |
virtual IRhRdkPostEffect * | NewPostEffect (void) const =0 |
Public Member Functions inherited from CRhRdkExtension | |
CRhRdkExtension () | |
virtual | ~CRhRdkExtension () |
virtual UUID | PlugInId (void) const =0 |
bool | Unregister (void) |
Public Member Functions inherited from CRhRdkObject | |
CRhRdkObject () | |
virtual | ~CRhRdkObject () |
virtual void * | EVF (const wchar_t *wszFunc, void *pvData) |
void | operator delete (void *buf) |
void | operator delete[] (void *buf) |
void * | operator new (size_t size) |
void * | operator new[] (size_t size) |
Protected Member Functions | |
virtual UUID | InterfaceId (void) const final override |
Additional Inherited Members | |
Static Public Member Functions inherited from CRhRdkObject | |
static void | CheckMemory (void) |
static void | PopulateDebuggingInfo (void) |
This class allows you to provide a factory for generating a custom post-effect plug-in (PEP).
|
finaloverrideprotectedvirtual |
Returns the unique interface id of this extension.
Implements CRhRdkExtension.
|
pure virtual |
Create the new PEP instance.