Rhino C++ API
8.13
|
#include <RhRdkRenderWindowEventSink.h>
Public Member Functions | |
virtual UUID | InterfaceId (void) const final override |
virtual void | OnLButtonDblClk (IRhRdkRenderWindow &rw, const ON_2iPoint &point)=0 |
virtual void | OnLButtonDown (IRhRdkRenderWindow &rw, const ON_2iPoint &point)=0 |
virtual void | OnLButtonUp (IRhRdkRenderWindow &rw, const ON_2iPoint &point)=0 |
virtual void | OnMouseMove (IRhRdkRenderWindow &rw, const ON_2iPoint &point)=0 |
virtual void | OnRButtonDblClk (IRhRdkRenderWindow &rw, const ON_2iPoint &point)=0 |
virtual void | OnRButtonDown (IRhRdkRenderWindow &rw, const ON_2iPoint &point)=0 |
virtual void | OnRButtonUp (IRhRdkRenderWindow &rw, const ON_2iPoint &point)=0 |
Public Member Functions inherited from CRhRdkExtension | |
CRhRdkExtension () | |
virtual | ~CRhRdkExtension () |
virtual UUID | PlugInId (void) const =0 |
bool | Unregister (void) |
Public Member Functions inherited from CRhRdkObject | |
CRhRdkObject () | |
virtual | ~CRhRdkObject () |
virtual void * | EVF (const wchar_t *wszFunc, void *pvData) |
void | operator delete (void *buf) |
void | operator delete[] (void *buf) |
void * | operator new (size_t size) |
void * | operator new[] (size_t size) |
Additional Inherited Members | |
Static Public Member Functions inherited from CRhRdkObject | |
static void | CheckMemory (void) |
static void | PopulateDebuggingInfo (void) |
This object is an RDK extension that allows a plug-in to find out about mouse activity in the render window. To use it, derive a class that implements each abstract method to respond to mouse events. Then register your subclass as follows:
The mouse event methods will be called when the user operates the mouse inside the view area (rendering) of any render window that was opened by your plug-in. You can use the supplied render window reference to determine which render window it is.
|
finaloverridevirtual |
Returns the unique interface id of this extension.
Implements CRhRdkExtension.
|
pure virtual |
Implement this method to respond to left mouse button double-click events.
|
pure virtual |
Implement this method to respond to left mouse button down events.
|
pure virtual |
Implement this method to respond to left mouse button up events.
|
pure virtual |
Implement this method to respond to mouse move events.
|
pure virtual |
Implement this method to respond to right mouse button double-click events.
|
pure virtual |
Implement this method to respond to right mouse button down events.
|
pure virtual |
Implement this method to respond to right mouse button up events.