Rhino C++ API
8.18
Main Page
Related Pages
Modules
Classes
Class List
Class Index
Class Hierarchy
Class Members
All
_
a
b
c
d
e
f
g
h
i
j
k
l
m
n
o
p
q
r
s
t
u
v
w
x
y
z
~
Functions
_
a
b
c
d
e
f
g
h
i
j
k
l
m
n
o
p
q
r
s
t
u
v
w
x
y
z
~
Variables
_
a
b
c
d
e
f
g
h
i
j
k
l
m
n
o
p
q
r
s
t
u
v
w
x
y
z
Typedefs
Enumerations
a
b
c
d
e
f
g
h
i
k
l
m
n
o
p
q
r
s
t
u
v
w
Enumerator
a
b
c
d
e
f
g
h
i
j
k
l
m
n
o
p
q
r
s
t
u
v
w
x
y
z
Related Functions
c
d
g
i
o
q
r
s
t
•
All
Classes
Namespaces
Functions
Variables
Typedefs
Enumerations
Enumerator
Friends
Modules
Pages
CRhinoAppFileSettings Member List
This is the complete list of members for
CRhinoAppFileSettings
, including all inherited members.
AlwaysDisplayAllFiletypes
() const
CRhinoAppFileSettings
clipboard_on_exit
enum name
CRhinoAppFileSettings
CRhinoAppFileSettings
()
CRhinoAppFileSettings
CRhinoAppFileSettings
(const CRhinoAppFileSettings &)
CRhinoAppFileSettings
Defaults
()
CRhinoAppFileSettings
delete_clipboard_data
enum value
CRhinoAppFileSettings
ExcludedFiles
() const
CRhinoAppFileSettings
FileSearchRecursiveDepth
() const
CRhinoAppFileSettings
ImportFileLayerMatchingOption
() const
CRhinoAppFileSettings
ImportFileLayerMatchingOptionDefault
enum value
CRhinoAppFileSettings
keep_clipboard_data
enum value
CRhinoAppFileSettings
LoadProfile
(CRhinoProfileContext &pc)
CRhinoAppFileSettings
m_always_autosave_before_commands
CRhinoAppFileSettings
m_autosave
CRhinoAppFileSettings
m_autosave_file
CRhinoAppFileSettings
m_autosave_increment
CRhinoAppFileSettings
m_autosave_meshes
CRhinoAppFileSettings
m_bCreate3dmBakFiles
CRhinoAppFileSettings
m_clipboard_on_exit
CRhinoAppFileSettings
m_copy_to_previous_rhino_version
CRhinoAppFileSettings
m_default_template_file
CRhinoAppFileSettings
m_enable_file_locking
CRhinoAppFileSettings
m_enable_file_locking_open_warning
CRhinoAppFileSettings
m_keep_multiple_recycled_autosave_files
CRhinoAppFileSettings
m_recycle_autosave_files
CRhinoAppFileSettings
m_save_view_changes
CRhinoAppFileSettings
m_template_files
CRhinoAppFileSettings
operator!=
(const CRhinoAppFileSettings &src) const
CRhinoAppFileSettings
operator=
(const CRhinoAppFileSettings &)
CRhinoAppFileSettings
operator==
(const CRhinoAppFileSettings &src) const
CRhinoAppFileSettings
prompt_user_when_clipboard_big
enum value
CRhinoAppFileSettings
RemoveDotFromRhlFiles
() const
CRhinoAppFileSettings
RemoveDotFromRhlFiles
(bool on)
CRhinoAppFileSettings
SaveProfile
(CRhinoProfileContext &) const
CRhinoAppFileSettings
SetAlwaysDisplayAllFiletypes
(bool on)
CRhinoAppFileSettings
SetExcludedFiles
(const ON_ClassArray< ON_wString > &)
CRhinoAppFileSettings
SetFileSearchRecursiveDepth
(unsigned int)
CRhinoAppFileSettings
SetImportFileLayerMatchingOption
(unsigned int import_file_layer_matching_option)
CRhinoAppFileSettings
SetWriteLocalTempFileWhenSaving
(bool on)
CRhinoAppFileSettings
WriteLocalTempFileWhenSaving
() const
CRhinoAppFileSettings
~CRhinoAppFileSettings
()
CRhinoAppFileSettings
Generated on Tue Apr 8 2025 16:23:46 for Rhino C++ API by
1.8.17