Rhino C++ API  8.6
Public Types | Public Member Functions | Public Attributes | List of all members
CRhinoCCXEvent Class Reference

#include <RhinoSdkIntersect.h>

Public Types

enum  EVENT_TYPE { CCX_NO_EVENT = 0, CCX_POINT = 1, CCX_OVERLAP = 2, CCX_EVENT_TYPE__FORCE__INT = 0xFFFFFFFF }
 

Public Member Functions

int Compare (const CRhinoCCXEvent &other) const
 

Public Attributes

ON_3dPoint m_A [2]
 intersection point(s) on first curve More...
 
double m_a [2]
 intersection parameter(s) on first curve More...
 
ON_3dPoint m_B [2]
 intersection point(s) on second curve More...
 
double m_b [2]
 intersection parameter(s on second curve More...
 
EVENT_TYPE m_type
 

Detailed Description

Copyright (c) 1993-2017 Robert McNeel & Associates. All rights reserved. Rhinoceros is a registered trademark of Robert McNeel & Associates.

THIS SOFTWARE IS PROVIDED "AS IS" WITHOUT EXPRESS OR IMPLIED WARRANTY. ALL IMPLIED WARRANTIES OF FITNESS FOR ANY PARTICULAR PURPOSE AND OF MERCHANTABILITY ARE HEREBY DISCLAIMED.

For complete Rhino SDK copyright information see http://www.rhino3d.com/developer.

Member Enumeration Documentation

◆ EVENT_TYPE

There are two valid curve-curve intersection events CCX_POINT - curves intersect in an isolated point a[0] = a[1] = first curve parameter A[0] = A[1] = intersection point on first curve b[0] = b[1] = second curve parameter B[0] = B[1] = intersection point on second curve

CCX_OVERLAP (a[0],a[1]) = first curve parameter range A[0] = intersection start point on first curve A[1] = intersection end point on first curve (b[0],b[1]) = second curve parameter range B[0] = intersection start point on second curve B[1] = intersection end point on second curve

Enumerator
CCX_NO_EVENT 
CCX_POINT 

curve-curve intersection point

CCX_OVERLAP 

curve-curve intersection overlap

CCX_EVENT_TYPE__FORCE__INT 

Member Function Documentation

◆ Compare()

int CRhinoCCXEvent::Compare ( const CRhinoCCXEvent other) const

Description: Compare "this" intersection event with "other". Parameters: other - [in] Returns: @untitled table -1 this < other 0 this = other +1 this > other Remarks: Compare is used to sort intersection events into canonical order.

Member Data Documentation

◆ m_A

ON_3dPoint CRhinoCCXEvent::m_A[2]

intersection point(s) on first curve

◆ m_a

double CRhinoCCXEvent::m_a[2]

intersection parameter(s) on first curve

◆ m_B

ON_3dPoint CRhinoCCXEvent::m_B[2]

intersection point(s) on second curve

◆ m_b

double CRhinoCCXEvent::m_b[2]

intersection parameter(s on second curve

◆ m_type

EVENT_TYPE CRhinoCCXEvent::m_type