Rhino C++ API
8.13
|
CRhinoLayerComboBox window. More...
#include <rhinoSdkLayerComboBox.h>
Public Member Functions | |
CRhinoLayerComboBox () | |
virtual | ~CRhinoLayerComboBox () |
}}AFX_VIRTUAL More... | |
int | AddLayerToList (const CRhinoLayer &layer) |
virtual int | CompareItem (LPCOMPAREITEMSTRUCT lpCompareItemStruct) |
CRhinoDoc * | Document () |
virtual void | DrawItem (LPDRAWITEMSTRUCT lpDrawItemStruct) |
const CRhinoLayer * | Layer (int list_index) |
int | LayerIndexFromListIndex (int list_index) |
int | ListIndexFromLayerIndex (int layer_index) |
int | LoadLayers (CRhinoDoc *doc, BOOL32 show_referenced=true, int set_current=-1) |
Operations. More... | |
BOOL32 | RemoveLayerFromList (int layer_index) |
int | SelectedLayerIndex () |
Protected Member Functions | |
virtual void | PreSubclassWindow () |
Protected Attributes | |
HPALETTE | m_hPalette |
Generated message map functions. More... | |
CRhinoLayerComboBox window.
Copyright (c) 1993-2017 Robert McNeel & Associates. All rights reserved. Rhinoceros is a registered trademark of Robert McNeel & Associates.
THIS SOFTWARE IS PROVIDED "AS IS" WITHOUT EXPRESS OR IMPLIED WARRANTY. ALL IMPLIED WARRANTIES OF FITNESS FOR ANY PARTICULAR PURPOSE AND OF MERCHANTABILITY ARE HEREBY DISCLAIMED.
For complete Rhino SDK copyright information see http://www.rhino3d.com/developer.
CRhinoLayerComboBox::CRhinoLayerComboBox | ( | ) |
|
virtual |
}}AFX_VIRTUAL
Implementation
int CRhinoLayerComboBox::AddLayerToList | ( | const CRhinoLayer & | layer | ) |
Description: Add layer to combo box, called by LoadLayers Parameters: layer [in] - layer to add Returns: List index for new item or LB_ERR if not added Remarks: If a layer is added to the layer table after LoadLayers is called use this method to expand the list
|
virtual |
Overrides ClassWizard generated virtual function overrides {{AFX_VIRTUAL(CRhinoLayerComboBox)
CRhinoDoc* CRhinoLayerComboBox::Document | ( | ) |
|
virtual |
const CRhinoLayer* CRhinoLayerComboBox::Layer | ( | int | list_index | ) |
int CRhinoLayerComboBox::LayerIndexFromListIndex | ( | int | list_index | ) |
Description: Get layer index associated with a specific combo box item Parameters: list_index [in] - list item to check Returns: Layer index or -1 on error
int CRhinoLayerComboBox::ListIndexFromLayerIndex | ( | int | layer_index | ) |
Description: Get combo box index from layer index Parameters: layer_index [in] - layer index to scan for Returns: combo box index or -1 if not found in list
int CRhinoLayerComboBox::LoadLayers | ( | CRhinoDoc * | doc, |
BOOL32 | show_referenced = true , |
||
int | set_current = -1 |
||
) |
Operations.
Description: Populate combo box with layer names and colors Parameters: doc [in] - document containing layer table set_current [in] - Layer index of item to set as current Returns: Number of layers added to list
|
protectedvirtual |
BOOL32 CRhinoLayerComboBox::RemoveLayerFromList | ( | int | layer_index | ) |
Description: Remove layer from combo box. Parameters: layer_index [in] - layer to remove Returns: TRUE if layer was removed from list FALSE if layer was not in list
int CRhinoLayerComboBox::SelectedLayerIndex | ( | ) |
Description: Get layer index associated with current combo box selection Returns: Layer index or -1 if nothing selected
|
protected |
Generated message map functions.