#include <RhRdkDeprecated.h>
◆ ~IRhRdkContentFactory()
virtual IRhRdkContentFactory::~IRhRdkContentFactory |
( |
| ) |
|
|
inlinevirtual |
◆ ContentInternalName()
virtual ON_wString IRhRdkContentFactory::ContentInternalName |
( |
void |
| ) |
const |
|
pure virtual |
◆ ContentTypeId()
virtual UUID IRhRdkContentFactory::ContentTypeId |
( |
void |
| ) |
const |
|
pure virtual |
◆ DeleteThis()
virtual void IRhRdkContentFactory::DeleteThis |
( |
void |
| ) |
|
|
pure virtual |
◆ EVF()
virtual void* IRhRdkContentFactory::EVF |
( |
const wchar_t * |
, |
|
|
void * |
|
|
) |
| |
|
inlinevirtual |
◆ Initialize()
virtual bool IRhRdkContentFactory::Initialize |
( |
void |
| ) |
|
|
pure virtual |
◆ IsBuiltIn()
virtual bool IRhRdkContentFactory::IsBuiltIn |
( |
void |
| ) |
const |
|
pure virtual |
◆ IsElevated()
virtual bool IRhRdkContentFactory::IsElevated |
( |
void |
| ) |
const |
|
pure virtual |
◆ IsKind()
◆ Kind()
virtual const wchar_t* IRhRdkContentFactory::Kind |
( |
void |
| ) |
const |
|
pure virtual |
◆ NewContent()
virtual CRhRdkContent* IRhRdkContentFactory::NewContent |
( |
void |
| ) |
const |
|
pure virtual |
◆ PlugInId()
virtual UUID IRhRdkContentFactory::PlugInId |
( |
void |
| ) |
const |
|
pure virtual |
◆ RebuildCache()
virtual void IRhRdkContentFactory::RebuildCache |
( |
void |
| ) |
|
|
pure virtual |
◆ RenderEngineId()
virtual UUID IRhRdkContentFactory::RenderEngineId |
( |
void |
| ) |
const |
|
pure virtual |